No proprietary driver for MX250 listed in ubuntu 16.04

I am running a fresh installed of Ubuntu 16.04 on an ASUS X512FL laptop, with secure boot turned off in the BIOS settings, and with two graphic cards:

  • Intel
  • NVIDIA MX250
user@laptop:~$ sudo lshw -C display
[sudo] password for user: 
  *-display               
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:130 memory:b2000000-b2ffffff memory:90000000-9fffffff ioport:5000(size=64) memory:c0000-dffff
  *-display
       description: 3D controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:129 memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:4000(size=128) memory:b4000000-b407ffff

I can’t seem to get the NVIDIA MX250 working (“nvidia-smi” not working) no matter what solutions I tried.

  1. I tried installing the open source driver from the "Additional Drivers" tab in the "Software & Updates". However, after restarting the Ubuntu won't boot and it stucks at the boot page. It shows message along this line:
    The system is running in low-graphics mode
    Your screen, graphics cards, and input device settings could not be detected correctly. You will need to configure these yourself.
    

    It seems that there is no “proprietary driver” listed here and I doubt this is the cause of the problem.
    Figure: https://drive.google.com/file/d/1eDHeJ5PGAD_RZWue-7Dw4P0mU56jVtSB/view?usp=sharing

  2. I tried running the following command but still it doesn't solve the problem. The result is the same with the above method.
    sudo apt-get purge nvidia*
    sudo add-apt-repository ppa:graphics-drivers/ppa
    sudo apt-get update
    sudo ubuntu-drivers devices
    sudo ubuntu-drivers autoinstall
    

Question
Does anyone have the same issue with NVIDIA MX250? Could you please instruct me on how to get the MX250 up and running on Ubuntu 16.04?

If you want to install a driver for your GPU, I suggest http://www.nvidia.com/drivers

Installing a linux driver on a modern laptop can require extra steps. Its generally a good idea to do some research and read the instructions provided.

If your target is CUDA, I would recommend one of two methods:

  1. start with a clean OS install, load a driver for your GPU from above, then follow the CUDA linux install guide instructions for runfile installer install. Install CUDA while deselecting the option to install the driver (you have already installed one).

or

  1. start with a clean OS install. Load everything using the network deb installer from http://www.nvidia.com/getcuda

In either case, if your goal is to install CUDA, I recommend reading the linux install guide:

https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

I am just wondering if the GPU drivers on the above site, when selecting Linux 64-bit as a target OS, universal or compatible with Ubuntu 16.04?

Yes, they are intended to be compatible with most common Linux 64-bit OSes. The runfile installer method that those drivers are packaged in is essential to the “universal” usability.

There exist other packaged drivers, as well as CUDA toolkit installers, that are packaged to fit the requirements of the package manager for a particular OS (e.g. .deb for Ubuntu). These are not “universal”.

Note that if you don’t do your research and read the instructions I’ve suggested, you may very well end up here:

just as you did before.

I have the exact same problem with ubuntu 18.04 on an Asus Zenbook

I cannot get the nvidia-smil to run properly

scott@small:~$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

scott@small:~$
scott@small:~$ lshw -C display
WARNING: you should run this program as super-user.
*-display
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:137 memory:c2000000-c2ffffff memory:a0000000-afffffff ioport:4000(size=64) memory:c0000-dffff
*-display UNCLAIMED
description: 3D controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:02:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: latency=0
resources: memory:c3000000-c3ffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:3000(size=128) memory:c4000000-c407ffff

Fixed. Turn off secure boot. That solves the problem. It is in the bios