Nondeterministic artifacts with T4 GPU H264 NVENC encoding

Hi,
We have been experiencing some artifacts when decoding NVENC-encoded H264 streams. We have reproduced the problem with multiple decoders and we have never experienced this problem before with other GPUs (G2.xlarge and G3s), so we think that this may be related to the new G4 GPU (an NVIDIA T4) or driver.

Those artifacts happen nondeterministically, maybe 10% of the time. Sometimes the artifacts are relatively small, but sometimes they cover most parts of the screen. When the artifacts appear they stick for a lot of frames, although we saw that a complete change of the input image tends to “clean” the artifacts. However, requesting IDR frames every time (for testing) didn’t solve this.

We are using NVENC with the VideoCodecSDK version 7.0.1 using the synchronous mode and the Directx11 integration as the input. I’ll provide a list of the parameters we use:

  • NV_ENC_H264_PROFILE_HIGH_GUID
  • NV_ENC_PRESET_LOW_LATENCY_HQ_GUID
  • NV_ENC_BUFFER_FORMAT_NV12_PL
  • width 1920
  • height 1080
  • averageBitRate : 8-12MBit/s (dynamically modified without IDR nor reset flags)
  • enableAQ : true
  • frameIntervalP: 1
  • gopLength: NVENC_INFINITE_GOPLENGTH
  • encodeCodecConfig.h264Config.enableIntraRefresh: 1
  • encodeCodecConfig.h264Config.intraRefreshCnt: 20
  • encodeCodecConfig.h264Config.intraRefreshPeriod: 40
  • encodeCodecConfig.h264Config.idrPeriod: NVENC_INFINITE_GOPLENGTH
  • encodeCodecConfig.h264Config.outputAUD: 0
  • encodeCodecConfig.h264Config.enableVFR: 1
  • encodeCodecConfig.h264Config.sliceMode: 1
  • encodeCodecConfig.h264Config.sliceModeData: 1440
  • rcParams.rateControlMode: NV_ENC_PARAMS_RC_CBR

The hardware specs are:

  • AWS EC2 g4dn.xlarge
  • AMI based on NVIDIA Gaming - Windows Server 2019

Do you know what could be triggering this? Could you point us to a possible workaround in case this is a bug outside our software?

Hi.

This is a known issue on Turing and will be fixed in an upcoming driver series.

Thanks.

Hi,

Thank you for your response. Is this issue happening independently of our configuration? Is there a roadmap or an ETA of the fix? Is there a beta driver with the fix?

Thank you very much,

David

Exact same problem here, any information regarding workarounds, beta-drivers or an ETA?

Please retest with r440 or above series driver for your platform.

Thanks.

Could you point us to the download page for that version?

We tried it from https://www.nvidia.es/Download/ and from https://www.nvidia.es/Download/Find.aspx but it never shows the 440.X version, only the 426.23 version.

We tried from the AWS page too (https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/install-nvidia-driver-windows.html) but that points to https://s3.amazonaws.com/nvidia-gaming/GRID-436.30-vGaming-Windows-Guest-Drivers.zip (436.30).

Should the drivers be provided by AWS?

Thank you

Hi, there has been no response regarding the previous question. I haven’t found the r440 drivers either.

Thank you.

Linux r440 beta release is available here:
https://www.nvidia.com/download/driverResults.aspx/152590/en-us

I’m sorry, but that points to a Linux driver, we are using Windows Server 2019

That url is neither pointing to a Windows driver, nor pointing to a driver that is compatible to Tesla GPUs.

Look forward to hearing from you.

Ok. Are looking for Tesla driver? It is not available yet.
Those drivers are available for Quadro/GeForce and you should find them at
https://www.nvidia.com/Download/index.aspx?lang=en-us

For AWS driver update, please check with AWS support directly.