Not able to Install NVIDIA Driver A100 on Ubuntu 20.04.5 LTS + CUDA 12.0/Any/all versions

Hi Team,

We can able to download the NVIDIA A100 on HPE ProLiant DL385 Gen10 Plus (BareMetal Server) but not able to install it.

Please find the below error message we tried for different machines

With CUDA - 12.0:

Unable to load the kernel module ‘nvidia.ko’. This happens most frequently when this kernel module was built against the wrong or
improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if another driver,
such as nouveau, is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA device(s), or no NVIDIA device
installed in this system is supported by this NVIDIA Linux graphics driver release.

With CUDA - 11.2:

WARNING: nvidia-installer was forced to guess the X library path ‘/usr/lib64’ and X module path ‘/usr/lib64/xorg/modules’; these paths were not
queryable from the system. If X fails to find the NVIDIA X driver module, please install the pkg-config utility and the X.Org
SDK/development package for your distribution and reinstall the driver.

Install NVIDIA’s 32-bit compatibility libraries?

Installation of the kernel module for the NVIDIA Accelerated Graphics Driver for Linux-x86_64 (version 460.106.00) is now complete.

No devices found

It looks their is difference of errors between we see above between 12.0 and 11.2, even we tried with Any as well

The /var/log/nvidia-installer.log shows below error

[ 304.210469] NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
NVRM: BAR1 is 0M @ 0x0 (PCI:0000:27:00.0)
[ 304.210482] nvidia: probe of 0000:27:00.0 failed with error -1
[ 304.210571] nvidia 0000:c3:00.0: enabling device (0140 → 0142)
[ 304.210709] NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
NVRM: BAR1 is 0M @ 0x0 (PCI:0000:c3:00.0)
[ 304.210721] nvidia: probe of 0000:c3:00.0 failed with error -1

For above PCI error we tried with pci=realloc/pci=realloc=off, still same issue

Please let us know the the correct NVIDIA driver that supports on ProLiant DL385 Gen10 Plus or let us know if we need to add some other configurations for install on the DL385 server.

Could you please assist us.