Not able to run the pipeline with 512x32 resolution

Hi,
I am using Nvidia Jetson AGX Xavier
Deepstream version 5.1
nvidia-l4t-core 32.6.1-20210726122859
TensorRT Version: 2.3.1+nv20.12

I am running a following pipeline in my Jetson.
gst-launch-1.0 -v filesrc location=/home/nvidia/video_512x32.h264 ! h264parse ! valve ! nvv4l2decoder ! fakesink

The above pipeline is not running and I am observing following error.
ERROR: from element /GstPipeline:pipeline0/GstH264Parse:h264parse0: Internal data stream error.
Additional debug info:
gstbaseparse.c(3611): gst_base_parse_loop (): /GstPipeline:pipeline0/GstH264Parse:h264parse0:
streaming stopped, reason not-negotiated (-4)
ERROR: pipeline doesn’t want to preroll.


I have observed 2 things.
1)
If source width or height is less than 48, then only this problem occurs. So if I run the video of resolution 512x48, then it runs fine.

2)
If I use ‘omxh264dec’ instead of ‘nvv4l2decoder’ plugin, then 512x32 video also works fine. Means ‘omxh264dec’ works with any resolution.

For the project necessity, I have to use ‘nvv4l2decoder’ only.
So How can I run the 512x32 stream with above pipeline?
Any help would be apperciated.

Hi,
Thanks for reporting this. We will try to replicate the issue and check.

Hi,

Is there any update regarding this ?

Thanks

Hi,
The issue is under investigation. Will update the status.

Hi,

Can you please give some update since it’s been more than 15 days.

Thanks

Hi,
We have checked this with our teams and confirmed 48x48 is the minimum resolution in spec of hardware decoder. So it is more like omxh264dec does not check this constraint closely, although 512x32 is decode-able. We will keep 48x48 in nvv4l2decoder to fir hardware spec.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.