Notice: CUDA Linux Repository Key Rotation

RUN sh -c 'echo "APT { Get { AllowUnauthenticated \"1\"; }; };" > /etc/apt/apt.conf.d/99allow_unauth'

RUN apt -o Acquire::AllowInsecureRepositories=true -o Acquire::AllowDowngradeToInsecureRepositories=true update
RUN apt-get install -y curl wget

RUN apt-key del 7fa2af80
RUN wget
RUN dpkg -i cuda-keyring_1.0-1_all.deb
RUN rm -f /etc/apt/sources.list.d/cuda.list /etc/apt/apt.conf.d/99allow_unauth cuda-keyring_1.0-1_all.deb

RUN apt-key adv --keyserver --recv-keys A4B469963BF863CC F60F4B3D7FA2AF80

RUN apt-get update && apt-get upgrade -y

This solution works for me thanks

it looks like it worked for me.
here is the code

apt-key adv --fetch-keys
apt-key adv --fetch-keys

add it before

apt-get update
1 Like

Is there a mailing list we can subscribe to that would have announcements like this in it? I’m having trouble finding anything that exists (that is not tied to a single user account). Would love to ensure our team here gets notifications as early as possible.

1 Like

This works fine for me

apt-key adv --fetch-keys

But this doesn’t work

apt-key adv --fetch-keys

I need to use the machine-learning repo but the public key is invalid now.

The wget command for cuda-keyring ($distro/$arch/cuda-keyring_1.0-1_all.deb) is giving 404 not found error.

Are you sure that $distro/$arch is being replaced as indicated in the repo?

@akashsjhs I think @Dgromov is right, you need to replace $distro/$arch in your command line with the appropriate values for your system from the list in the original post.

–2022-05-05 17:54:48--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 404 Not Found
2022-05-05 17:54:48 ERROR 404: Not Found.

is the site down?

@thaha1 We do not yet support Ubuntu 22.04 in CUDA and there is no corresponding repository.

1 Like

in the above replace $distro/$arch section , why is there “ubuntu2004/x86_64” ?

@thaha1 I think you mean why is there “ubuntu2204/x86_64”? Good point, in our CUDA 11.7 release coming out next week we will support it and that repo will be live, but it’s not supported for 11.6 and earlier.

My copy/paste error got it onto the list a little bit early, apologies for that.

1 Like

Hi @roarmstrong ,

Can you check on the Machine Learning repo as well. It’s key is also rotated but it don’t have new key on the repo

Hi @nguyenductin
We did not update the signing key (7fa2af80) for the Machine Learning repositories. Please consider installing a newer version of cuDNN, NCCL, and/or TensorRT products, which are available in the CUDA repositories.

1 Like



it seems to work for me.

hello @roarmstrong ,

I have the same issue running on Jetson AGX ORIN using this tutorial here from NVIDIA and I could not resolve the problem I tried a lot of threadds and topics here and on github nothing worked for me.

here is my log below

in my case:

  • $distro == ubuntu2004
  • $arch == sbsa

Thank you in advance,


I have started to get similar error again over the last two days but one associated with the hpc-sdk:

W: GPG error: InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY F338EA0E0105AB24

I have tried all the solutions prescribed here but nothing works. When I manually try and install the key: it gives me this error:

______@linux-machine:~$ sudo apt-key adv --fetch-keys$distro/$arch/
Executing: /tmp/apt-key-gpghome.czHQoeeMFn/ --fetch-keys
gpg: requesting key from ‘
gpg: WARNING: unable to fetch URI No data

I don’t think this is an HPC SDK error but I will send you email and will try to work with you to find a solution. CUDA also does not appear to have a key named