Notice: CUDA Linux Repository Key Rotation

in the above replace $distro/$arch section , why is there “ubuntu2004/x86_64” ?

@thaha1 I think you mean why is there “ubuntu2204/x86_64”? Good point, in our CUDA 11.7 release coming out next week we will support it and that repo will be live, but it’s not supported for 11.6 and earlier.

My copy/paste error got it onto the list a little bit early, apologies for that.

1 Like

Hi @roarmstrong ,

Can you check on the Machine Learning repo as well. It’s key is also rotated but it don’t have new key on the repo

Hi @nguyenductin
We did not update the signing key (7fa2af80) for the Machine Learning repositories. Please consider installing a newer version of cuDNN, NCCL, and/or TensorRT products, which are available in the CUDA repositories.

1 Like



it seems to work for me.

hello @roarmstrong ,

I have the same issue running on Jetson AGX ORIN using this tutorial here from NVIDIA and I could not resolve the problem I tried a lot of threadds and topics here and on github nothing worked for me.

here is my log below

in my case:

  • $distro == ubuntu2004
  • $arch == sbsa

Thank you in advance,


I have started to get similar error again over the last two days but one associated with the hpc-sdk:

W: GPG error: InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY F338EA0E0105AB24

I have tried all the solutions prescribed here but nothing works. When I manually try and install the key: it gives me this error:

______@linux-machine:~$ sudo apt-key adv --fetch-keys$distro/$arch/
Executing: /tmp/apt-key-gpghome.czHQoeeMFn/ --fetch-keys
gpg: requesting key from ‘
gpg: WARNING: unable to fetch URI No data

I don’t think this is an HPC SDK error but I will send you email and will try to work with you to find a solution. CUDA also does not appear to have a key named