Nsight failed to find session

Hello, when I used nsys profile ./my_test it said that failed to find session: profile-my_test-1355424.

A couple of questions, does it work with just “nsys profile my_test”?

What version of Nsys are you using?

I have tried to profile many functions, but the result was that I couldn’t find the session.
My version is 2022.2.1.

Okay, first check for zombie Nsys processes, make sure there are no Nsys instances running on the system.

Second run “nsys sessions list” to see if you have any extraneous sessions. You shouldn’t.

Nsys is definitely looking for a session names profile-my-test, when it should be profiling my_test. It looks to me like it is confused by the ./ in the command. Certainly the ./ is unnecessary.

I tried the above steps, but still couldn’t find the session.
Running error:Failed to find session:profile-my_test-1507850.
After the failure, I used ps -ef | grep nsys
I find there is a process nsys --session-name=profie-my_test-1507850

Okay, kill any and all nsys processes running on the system. Update to 2023.3. And try again with just “my_test” instead of “./my_test”