Nsight systems 2019.5.1 cannot open qdrep file

I’ve used nsys profile cli tool and genrate the qdrep file, but when I try to import into Nsight system I’ve got only *.qdstrm file in open box dialog.

I’ve tried both 2019.3.7 version and the latest 2019.5.1.

Do you have any ideas what could be wrong? And how can I save qdstrm file, because it deletes automatically when QdstrimImporter is called.

Importing the qdstrm file using /usr/local/cuda-10.1/nsight-systems-2019.3.7.5/Host-x86_64/QdstrmImporter.

Importing...

Importing [==================================================100%]
Saving report to file "/home/dellboy/nvidia_nsight_systems/report2.qdrep"
Report file saved.
Please discard the qdstrm file and use the qdrep file instead.

Removed /home/dellboy/nvidia_nsight_systems/report2.qdstrm as it was successfully imported.
Please use the qdrep file instead.

Your problem is that you are using “import” which is looking for unconverted .qdstrm files, and you need to be using “open” because your CLI result was successfully converted to a .qdrep file.

The .qdstrm file only works for a particular version of the CLI and GUI, so Nsight Systems attempts to convert it to the forward compatible .qdrep format as soon as possible.

Hi,

I am having a different problem.

When I run Nsight and try to “Open” a .qdrep file, it opens it as a text file instead of a profiler view.

Am I doing something wrong?

  • Ron

What Nsight are you using? Are you using Nsight Systems or one of the other Nsight tools?

Also, what version?

I also have this issue, Nsight opens the file like a text file.
It seems that Nsight Eclipse Edition cannot recognize a .qdrep file.

My version of Nsight is:
Nsight 10.0.0.201808260220 com.nvidia.cuda.ide.product null

On Ubuntu 16.04

–CLew

Nsight is a product family, not one product.

.qdrep files are report files generated by Nsight Systems (GUI or CLI) they can be opened or post processed by Nsight Systems, but not any of the other Nsight tools (Nsight Compute, Nsight Graphics, Nsight VSE, Nsight Eclipse Edition).