Nsight Systems 2020.5 Crashes When Run as Normal User

Whenever I run the Nsight Systems GUI app as an ordinary user, it typically crashes after a collecting profiling data on an application. This crash occurs after the profiling run, immediately after loading and processing all the samples, but just before displaying the Nsight Graphics GUI showing the collected profiling data). The stack trace is shown below.

However, I noticed Friday that if I run the Nsight Systems GUI app as an elevated user, then it does not crash.

The Nsight Systems GUI is apparently trying to perform some file system reads or writes via the boost_filesystem library. But it doesn’t say what file or directory it’s trying to access, so I can’t do much toward further troubleshooting of this. The fact that it executes without crashing when run as an elevated user suggests possibly a permission issue Nsight Systems isn’t expecting.

Any tips for troubleshooting this one? I’d like to run Nsight Systems as an ordinary user, as I gather is the expected method for invoking it.

My Config:

  • Nsight Systems 2020.5.1
  • Win 10, ver 1909
  • RTX 2080 non-Ti
  • 441.87 drivers
Reason:    Unhandled C++ Exception
Address:   0x7fffe8113b29
Assertion: Unknown assertion type 0x00000000

Thread 0 (crashed)
 [0]  KERNELBASE.dll + 0x43b29
 [1]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x169d8
 [2]  KERNELBASE.dll + 0x43b29
 [3]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x169d8
 [4]  0x7fffdf2d0000
 [5]  ntdll.dll + 0x1f41f
 [6]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x2f0c
 [7]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x1c000
 [8]  0x7fffdf2d0000
 [9]  ntdll.dll + 0x4130d
 [10]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x169d8
 [11]  VCRUNTIME140.dll + 0x6210
 [12]  0x7fffdf2d0000
 [13]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x169d8
 [14]  0x7fffdf2d0000
 [15]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x6211
 [16]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x11670
 [17]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x11670
 [18]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x121b8
 [19]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x11670
 [20]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x4100
 [21]  boost_filesystem-vc142-mt-x64-1_70.dll + 0x6de0
 [22]  ucrtbase.dll + 0x114cb
 [23]  QuadDPlugin.dll + 0x21c609

Working offline with Doron Ofek of NVIDIA Developer Tools, I verified that an updated NVIDIA Nsight Systems 2020.5.1.85-5ee086b (Windows-x64) binary they produced does in-fact resolve this problem. The GUI no longer crashes after loading and processing the collected samples.

Thanks again for the fix!