Nsight System fail to start profiling on win10

RuntimeError (120) {
TargetSideError (1100) {
ErrorText: Throw location unknown (consider using BOOST_THROW_EXCEPTION)
Dynamic exception type: class boost::exception_detail::clone_impl<class boost::exception_detail::current_exception_std_exception_wrapper >
std::exception::what: bad conversion
class std::range_error
ServiceName: AnalysisService
MethodName: Init
InternalError (105) {
OriginalExceptionClass: class boost::exception_detail::clone_impl<class boost::exception_detail::current_exception_std_exception_wrapper >
}
}
}

Nsight Systems Version: 2020.3.2.6-87e152c Windows-x64.
cuda 10.2
Nvidia Studio Driver 461.40

What does the error above mean? How can I fix it?

Two things you might try:

  1. Update to the latest Nsight Systems and retry (2021.1 currently)
  2. Run Nsight Systems as Administrator and retry.

I suggest #2 as I hit a problem a few months back on Win10 where on older version of Nsight Systems would crash after profiling collection (with boost APIs on the stack) unless run as an elevated user. That’s been fixed in more recent versions, but you’re running an older version. See this link for details:

I tried to run it as an administrator, doesn’t work.
I updated to NVIDIA Nsight Systems, 2020.5.1.85-5ee086b Windows-x64, ran it as an administrator, still doesn’t work.
The latest version I see here is 2020.5 NVIDIA Nsight Systems | NVIDIA Developer.

Here are the error details:
Full error information:
StartAnalysisError (4105) {
RuntimeError (120) {
OriginalExceptionClass: class boost::exception_detail::clone_impl
OriginalFile: B:\Src\Default\QuadD\Host\Analysis\Clients\AnalysisHelper\AnalysisStatus.cpp
OriginalLine: 80
OriginalFunction: class Nvidia::QuadD::Analysis::Data::AnalysisStatusInfo __cdecl QuadDAnalysis::AnalysisHelper::AnalysisStatus::MakeFromErrorString(enum Nvidia::QuadD::Analysis::Data::AnalysisStatus,enum Nvidia::QuadD::Analysis::Data::AnalysisErrorType::Type,const class std::basic_string<char,struct std::char_traits,class std::allocator > &,const class boost::intrusive_ptr &)
ErrorText: Failed to start analysis.
}
}

Profiling options:
DeviceId: “Local”
EventTypes {
Items: CpuCycles
Items: Cuda
}
RateHz: 1000
HowToStart: Delayed
HowToStop: Manual
DeviceType: Windows
DeviceDisplayName: “XIAOWEI-LIU”
WindowsPerfOptions {
retainEtwFiles: true
}
Processes {
HowToAttach: LaunchAnother
Command: “F:\gpu_cloth\build\cloth_sim.exe”
WorkingDirectory: “F:\gpu_cloth\build”
UserName: “Administrator”
CollectCudaTrace: true
CudaFlushPeriodically: true
CudaFlushPeriod: 10000000000
CudaSkipSomeApiCalls: true
CollectGPUMemoryUsage: true
}
StartDelayMilliseconds: 10000

Sorry, my mistake. I was crossing latest version numbers for Nsight Systems (2020.5) and Nsight Graphics (2021.1).