Numerous warnings when compiling the kernel driver package

When compiling the driver package on Gentoo (x11-drivers/nvidia-drivers), a whole lot of warnings gets emitted by both GCC and Clang. When trying to match the CFLAGS for that specific package, that is the compiler flags for the non-Kbuild segment, with the compiler flags that Kbuild emits in order to work around CFI violation in rm_kernel_rmapi_op · Issue #439 · NVIDIA/open-gpu-kernel-modules · GitHub, some of the warnings get turned into errors, specifically a function declaration without a prototype is deprecated in all versions of C [-Wstrict-prototypes] at the very least. As I’m stuck on the proprietary kernel module due to having an MX230 dGPU, I’m reporting this here instead of in the open-gpu-kernel-modules repository.

As there are way too many warnings to list them all here, I tried to upload the entire build log, but the forum returned an error after the upload seemingly completed, even when I tried it a second time. It wasn’t a useful error, just “Sorry, an error has occurred.”. The log is ~16MB in size in case that matters. I would prefer to upload the file directly to the forum, but I can use WeTransfer or another service if need be. I’ll wait for a response before moving forwards with an external file-sharing service though.

Have a nice day!

Edit: So, compressing the text file with gzip --best reduced the file size substantially — it was more than I expected to be honest, dropping down to only half a megabyte — but the forum still returns a nondescript error when uploading reaches 100%, just like with the uncompressed file. Is it because my forum account is too new or something?