Nvcc fatal : Unsupported gpu architecture 'compute_35'

I have been encountered with the following error when i try to make my environment

nvcc fatal : Unsupported gpu architecture ‘compute_35’
CMake Error at project_main_gui_rceds_v4_lib_generated_im2col_kernels.cu.o.cmake:220 (message):
Error generating

nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2023 NVIDIA Corporation
Built on Tue_Feb__7_19:32:13_PST_2023
Cuda compilation tools, release 12.1, V12.1.66
Build cuda_12.1.r12.1/compiler.32415258_0

About OS:
Ubuntu 20.04

GeForce GTX 1070

Would appreciate if the issue gets solved. Thank you and good day

CUDA 12.x has dropped support for Kepler compute 3.x devices.

The minimum supported compute capability is 5.0 in CUDA 12.

If you require support for cc3.5, you will need to use an older CUDA version, however your GTX 1070 is a cc6.1 device and it is supported by CUDA 12. If you want to tackle it that way (recommended), then look thru your project build system (CMakeLists.txt, etc.) and find out where/how compute 3.5 (compute_35) is being requested and try changing that to cc 61 (compute_61).

I won’t be able to help with cmake questions.

1 Like

Thank you for highlighting the issue. My CMakeLists.txt was actually calling for a couple of supported version, which also included 3.5. Removing 3.5 solved it.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.