NVCUVID problem with GTX960M

Hi,

It seems that the GTX960M Hardware decoder has a problem. I receive an H264 stream that I want to decode. The H264 stream is a Windows 10 stream and the last Macroblocks are not decoded like you can see on the next image (bottom right corner):

http://hpics.li/b5112a5

My colleague who worked with me on the same project had a GTX965M in his laptop and he doesn’t have the problem. We try on another computer with a 960M and the problem is the same.

Do you have any idea what is wrong with this GPU?

For information the sample doesnt worked too with the GTX960M and H264 streams.

Current driver : 378.78

Someone could answer me if the problem is known?

Can you please share the bitstream?

I test it with the sample : NvDecodeD3D11 and NvDecodeD3D9 in the Video_Codec_SDK_7.1.9.

My input is a h264 stream encoded with FFMPEG.

We test it with my collegue with my GTX960M. we’ve got the problem of last macroblock. On his laptop there is no problem with the same code on a GTX965M. We test it on a third laptop with GTX960M like me and we have exactly the same problem than I. So i suppose the problem come from the GPU or the GPU driver.

I uninstall the last driver to install an old one but nothing happened so i Re-install the new one for nothing better.

Could you test with a GTX960M and a h264 stream in your office?

Thank you for your quick response

I share you 2 sample encoded with ffmpeg.

Can you test it with NVDECODED3D11 sample with a GTX960M and a GTX965M and focusing the last block on the bottom right corner of the frames.

https://www.dropbox.com/s/i48l5jb3o38xf09/video.zip?dl=0

We were able to decode Sample3.h264 without any issues.
Sample.h264 seems like an erroneous stream. Apart from that it also has a resolution change (in which case you will have to destroy and re-create the decoder with the new resolution). Can you check this with ffmpeg or reference decoder?

Can you try to enable the flag b_Framestep to true and check the Frame from 16 to 80 and look the bottom right corner?

This is 2 capture of the sample3.h264 : https://www.dropbox.com/s/r4dojkaob13grc8/Capture.rar?dl=0

The sample.png is just a print screen and the block.png is a zoom of the 2 block which are note well decoded.

Just to remember :

  • The problem appears with the GTX 960M and not with GTX 965M.
  • The sample is a capture of a windows so this is normal if there is 2 windows toolbar on the screenshot. The bottom one is my computer windows toolbar and the second one is the windows toolbar of the video.

Thanks for your response

PS : The first sample is bugged we know the problem and it is fixed.