NVDIA Tesla T4 Driver always error This device cannot start. (Code 10)

This error shows up under “device manager” in windows. I tried windows 10 and windows server 2022 on two different machines. One a workstation and the other Supermicro Server.

The driver installed was 516.94-data-center-tesla-desktop-win10-win11-64bit-dch-international.exe

The error that shows is:

This device cannot start. (Code 10)
Insufficient system resources exist to complete the API.

Note both systems have plent of resources.

Note that we tried also installing in ESXi and also the driver doesn’t seem to work.
nvidia-smi shows the follwoing
Device not found

Anybody know why no driver is recognizing the card properly?

Hi,

What is the use case? Seems to be a vGPU use case and wojld require the vGPU driver and licenses. Please try to start with a eval for vGPU and the vGPU driver.

Regards Simon

I have the same problem. I am using Telsa P4. I am not using vGPU. just do CUDA operations.

CUDA on Windows? It doesn’t matter if you use vGPU or not. Without vGPU driver you can only use TCC mode on Windows.

Yes, I just use it to do some compute. I don’t need to use vGPU. When I try to use nvidia to adjust the mode I get the following error “`
C:\Windows\system32>nvidia-smi -g 0 -dm 1

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running. This can also be happening if non-NVIDIA GPU is running as primary display, and NVIDIA GPU is in WDDM mode.
`”
How should I fix it?