Nvdsvideotemplate not working

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU) - Tesla T4 **
• DeepStream Version - Deepstream-6.2
• JetPack Version (valid for Jetson only)
• TensorRT Version -
• NVIDIA GPU Driver Version (valid for GPU only) - 525.85.12
• Issue Type( questions, new requirements, bugs) - Query
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)


I am trying to run the sample pipeline command for single stream as mentioned in Gst-nvdsvideotemplate — DeepStream 6.2 Release documentation (nvidia.com).
However, I observed that “libcustom_impl.so” is not present in my Nvidia DeepStream docker. Am I supposed to bring/install it from somewhere else?
I did find the lib/libcustom_videoimpl.so. However, even though using the same does runs the Gstreamer command, the output video does not show up.
I have the following questions -

  1. How to correctly run the nvdsvideotemplate plug-in and which .so to use?
  2. How to determine what each .so actually does?
  3. Is there a way to see the .cpp file from which each .so file is built? I want to create my own .so and thus want to see how I can write the code.


You can refer to the demo below to learn how to use the nvdsvideotemplate: https://github.com/NVIDIA-AI-IOT/deepstream_tao_apps/tree/master/apps/tao_others/deepstream-gaze-app.

Thanks for providing the link. However, I don’t see the use of a Gstreamer command to run the pipeline. I also don’t see the creation/use of any .so file here. Can you please suggest any examples where those are used?

It’s just a demo to teach you how to use the Nvdsvideotemplate. The .so needs to be implemented based on your own functionality. In this demo, the .so is libnvds_gazeinfer.so.

I tried a simpler command. I tried using the following command -
gst-launch-1.0 filesrc location=./samples/streams/sample_720p.264 ! h264parse ! nvv4l2decoder ! nvdsvideotemplate customlib-name=“./lib/libcustom_videoimpl.so” customlib-props=“scale-factor:0.5.0” ! nvvideoconvert ! nvv4l2h264enc ! h264parse ! mp4mux ! filesink location=./result.mp4
And this worked. However, if I use the sample video sample_1080p_h264.mp4, the video fails with the error unsupported format.
Does that mean this plugin is not supported for 1080p videos? Or is this particular custom plugin (/lib/libcustom_videoimpl.so) not supported for 1080p?

1 Like

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

If you use mp4 file, you need to change the pipeline like: gst-launch-1.0 filesrc location=xxx ! qtdemux ! h264parse ! nvv4l2decoder........

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.