Nvidia 319.17 bug on Ubuntu 13.04

Hi,
I’m encountering a bug in nvidia-319.17 Linux driver. I’m on Ubuntu 13.04 64-bit. Here is kernel log: http://paste.ubuntu.com/5632947/
When installing 319.17 I followed this tut: http://paste.ubuntu.com/5601226/

BTW, I have tied bumblebee and other older nvidia drivers like 304 and 310 and 313, but all of them have same or very similar bug and I get a black screen and kernel oops. Thought it was a bumblebee issue, but now its seems like nvidia driver problem, because when using 319 I have purged bumblebee.

This is kernel oops of nvidia-304: http://paste.ubuntu.com/5632989/
This is kernel oops of nvidia-313:http://paste.ubuntu.com/5632994/

I’m on: Linux plastic-lap 3.9.0-030900rc6-generic #201304080035 SMP Mon Apr 8 04:36:25 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

lspci gives me:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF119M [GeForce GT 520MX] (rev a1)
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 130 (rev 34)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)

My laptop model: Samsung NP300V5A-S07EE

If you need some more info on my system write here.

Thanx.

Can you try to upgrade your kernel (or try an older kernel) and see if the problem goes away? Anything in particular that you’re doing when the issue happens? Is it reproducible?

See for more ideas/suggestions if the advice above doesn’t help: http://askubuntu.com/questions/218260/bug-unable-to-handle-kernel-null-pointer-dereference-at

This bug I get with all Ubuntu 12.10 and 13.04 kernels i.e. 3.8 and 3.9 and all others. This bug is “very” reproducible with mine machine, it’s crashes every time I try to load Nvidia drivers regardless of driver version. If I use older drivers with bumblebee it crashes if I use newest drivers with native optimus support it crashes. It’s kinda weird, but it seems that this bug affects only my machine… Cause for other with GT520MX everything works (or I just couldn’t find bug reports).

I have this same exact issue on Ubuntu anything after version 11.10 on the following system: http://speccy.piriform.com/results/hm37LEXadBVEoAUgVWVkSNU I was trying to upgrade from 12.10 using a 3.2 Kernel from Server LTS Line of the Ubuntu Flavor to 13.04 after resizing a hard drive to shrink my Windows Partition, yet upon reboot X fails to respond, and I get the aforementioned pastebin errors with different addresses, but they are very identical. The only drivers that I found that worked are with 3.2 Kernel and nVIdia-experiemnal-310 the generic ones fail, the updated ones fail, haven’t tried installing the official ones from nVidia yet but I suspect that it would fail as well.

And to note, this happens across a multitude of Linux Distributions. So its not just your lap top.

Thanks God I’m not alone. Maybe now this bug will get some more attention.

cryptodan << Have you tried to report this to Ubuntu as a kernel bug? I have not, maybe they also would have any ideas…

Hello Plasticas, you’re not alone with your problem.

I have exactly the same error structure.

My system now: 3350P I5 with 20GB RAM GT 630 with 4GB DDR3 Ram
Before: E8400, 8GB RAM GT8600 / GT 630 above

I start the story:

With Kubuntu 11.10 / 12.04 / 12.10 and kernel 3.2 / 3.5 and 3.7 everything runs with the system …

The Kubuntu - system is basically 64-bit Installs

After seeing the system KB 12.10 - 64 bit’ve renewed with the 3.8 kernel, caught the error messages … First I thought the system was broken.
This was now 7 years old and I thought “new is necessary anyway” … see above “My system now” ;)

But get it wrong thought were the error messages.

After countless installations, believe in one weekend about 30 times newly installed the system. Various possibilities have been eliminated. I also can get that the Nvidia driver with the 3.8 kernel does not “speak”

Only the introduced version of Kubuntu with the 310.44 drivers works without errors. All 310 experimental or 313.x or 319.x bring the system to crash.

According Dsmeg Kubuntu can not access the files with the Nvidia drivers, although it built cleanly before.
For “big” errors, the system was re-installed, so that you always tested in a “fresh” system.

I already have a kernel bug report sent, no reply so far.

We need a solution, you can not just fall back on an old driver only.

I hope, you’ll understand my “old-english”

So Nvidia, any Ideas ?

Hi Procus,
could you send me the link to kernel bug? I will mark “Affects me”.

Hi Plasticas, of course… ;)
https://bugs.kde.org/show_bug.cgi?id=318562
https://bugs.kde.org/show_bug.cgi?id=318840

for both i used the bugs kde system…maybe it helps…

I’ve tried it again with the 319.17 drivers and kernel 3.8.x (19). The same, window viewing remains black, not even lightdm starts. You have to deinstall and then install the driver again by a native driver console.

Some more information…
after i try to install 319.17 (we know it dosn’t works) i, try to install driver 313.x-updates…

Now, this will work…??? Driver - No. 313.30

new Information, with the Driver 313.30 you’ve the same sh… (Problem). System hangs, black Screen,
Kernel Panic. I re-installed Driver 310.44 that works…

You say that Nvidia-310.44 works? On witch kernel version? I would test that on my system. In weekend I tested 3.2 and 3.5 kernels with nvidia-304 driver, both fail in same way with kernel oops.

I dropped back to Ubuntu 12.04 LTS Server, as the 3.8 Kernel is far to buggy for my liking. Ubuntu needs to solve this, before they lose their customer base.

I also had issues with 313.xx stable driver. I am using the 310 experimental release and it is far more stabler.

This is not a solution for me, I’m kind of bleeding edge guy. And I have tested 12.04 kernel on 13.04 with same results…so I doubt stock 12.04 would get rid of the bug…

It has fixed it for me, and my system has been running stable and non stop for the last 48 hours. I downloaded Ubuntu 12.04.2 LTS Server, installed it. Ran apt-get update then tasksel and installed Ubuntu Desktop after installing 310.xx Experimental Driver. I can now game on it and it starts up nice and fast. Everything is stable.

304.xx and 313.xx all give me the above bug, the 310 experimental driver does not. I tried the 310 on the 13.04 and it failed as well.

I also tried the experimental driver with the 3.8 13.04 Kernel and it to failed and gave me the above kernel panic.

I cant even download the regular ubuntu 11.10, 12.04, or 12.10 and use it because of this issue.

I have the same problem with my 520mx graphic card in ubuntu 12.10, 13.04 with all new kernels.
The graphic card is only working with 12.04 and kernel 3.2.0-41-generic-pae running with Bumblebee Project. (with option " optirun name=program" ). My laptop has Optimus Technology.
All the drivers don’t work with any kernel which is newer than series of 3.2. and are not PAE version.

I instaled this driver (319) alone (not Bumblebee) and after reboot I don’t see any Menu in my Ubuntu 12.10 or 13.04. This problem is not only with 319. It is with 304,310 … etc in all kernels newer than 3.2.

So what is the problem with this graphic cards and your proprietary drivers NVidia?
And why the graphic cards is working with Nouveau drivers and not with your drivers?

Finaly it got fixed. Now my setup is:
Bumblebee 3.2.1
linux-kernel 3.8.0-26-generic
Nvidia 325.08

I had to repackage bumblebee-nvidia to work around dependencies problem (it allways wants older nvidia drivers version like 310 and/or 313).

So I think this bug may be marked as fixed.

I looked up what Bumblebee was, and I do not consider that a fix it is more of a work around. It should work without the use of special tools. I am still hesitant on installing 13.04 and the latest kernel because it may result in the kernel panic and a black screen. Until one can confirm that 13.04 can be installed without a kernel panic this is not fixed.

I may have found the issue to why any newer kernels and ubuntu releases failed on my computer. The reason is that my video card was slowly dying. I recently started getting random lock ups in Linux and unable to view the login page to interact with linux in GUI mode. I was however able to ssh in and do it via command line, but on one occasion the system froze up in CLI mode. I rebooted to Windows, and was unable to interact with it. I put in my GTS 8800 SC Card, and low and behold I am now able to run Ubuntu 13.10 with 319 drivers flawlessly.

I will see if I can locate nvidia-331 drivers and see if I can get those to work.

I can confirm my latest post, I am now using a EVGA GeForce GTX 670 on 14.04 with 331 driver series and Kernel 3.13 tree without any issue. It could be that the GeForce 580 series contained a hardware or BIOS issue that caused issues in 13.04 and up with 31x driver series and newer kernels.