Bumblebee issue in fedora 18/19 with nvidia drivers newer than 310.51 and xorg-x11-server-Xorg-1.14

Hello. I am having a really weird problem and I am not sure if this is the right place to go for help. But it seems like the place of last resort. So here goes nothing…

I’m having a problem with my optimus laptop (Lenovo ideapad y470) using some software called bumblebee. The issue I’m having is with the nvidia drivers newer than 310.51 and xorg-x11-server-Xorg-1.14.2-4.fc19 or xorg-x11-server-Xorg-1.13.3-3.fc18

When I try to compile any newer video drivers shim than 310.51 on either fedora 18 or fedora 19 everything is fine until I use the nvidia card once with “optirun”. When I do that, and exit any programs the xorg-x11-server crashes. Due to the xorg server crashing, the nvidia kernel module cannot be unloaded. Due to that, the card stays on and excessive power is consumed by any optimus laptop until a reboot.

Given the statements by nvidias PR dept:

http://www.phoronix.com/scan.php?page=news_item&px=MTEyMjk

“And as a result, we’ve recently made Installer and readme changes in our R295 drivers that were designed to make interaction with Bumblebee easier.”

I am unsure if bumblebee software is a technology that nvidia is willing to support under Linux. But many people have been asking me to update my nvidia drivers rpm and it seems like until and unless this bug could be fixed it will never be possible to upgrade to anything higher than version 310.51 which would leave many newer laptops unsupported on Fedora 18/19/20. Newer drivers work fine on fedora 17 and RHEL 6 but fedora 17 will be end of lifed soon. So I’m more worried about fedora 18/19/20.

Here are some links to the files I think you guys might need?

http://people.engr.ncsu.edu/gsgatlin/nvidia-bug-report.log.gz
http://people.engr.ncsu.edu/gsgatlin/Xorg.8.log
http://people.engr.ncsu.edu/gsgatlin/messages

You can see where it crashes in the “messages” log in this line:

Jul 16 13:09:14 y470b bumblebeed[4452]: [ 308.239774] [ERROR][XORG] (EE) Segmentation fault at address 0x0

The command I executed was “optirun -b primus glxgears”

(without quotes)

Here is a link to documentation that may help to reproduce the problem if you guys are willing to work on it: http://techies.ncsu.edu/wiki/bumblebee

You need to remove /etc/sysconfig/nvidia/NVIDIA-Linux-x86_64-310.51.run and replace it with
/etc/sysconfig/nvidia/NVIDIA-Linux-x86_64-319.32.run and then run /usr/sbin/bumblebee-nvidia by hand in order to duplicate this problem.

Please let us (the rpm packager, me and also the bumblebee developers) know if this is the kind of bug nvidia would be willing to try to fix or if I should inform all fedora users that its been a nice ride for like a year but that the party is just about over? :)

Please let me know if I can provide further information concerning this particular bug. Thanks for your time and consideration.

issue433.tar.gz (83.5 KB)

I have a Lenovo Y580 and it has the same issues as described above. Can any Dev from Nvidia look into this?
We are not able to use the lastest drivers for Fedora 19 with the current situation as noted by Gary from the previous post.

Slight correction. Its crashing with anything newer then version 313.30. (Something changed in 319.XX) But 3.13.30 does not crash on optirun exit. So version 319.12, 319.17, and 319.27 and 319.32 all do not work well with newer version of fedora on optimus laptops with bumblebee 3.2.1. There is also a issue on github here if that helps…

Thanks for your time and please let me know if I can provide further information.

I’ve recently just upgraded to Fedora 19, and I would like to get Cuda 5.5 (RC) running on my system which requires 319.x. It would be really great if the NVIDIA team could look into this.

Could someone at nvidia please look at this? I have this issue on fedora 19. I have tried both 319.49 and 325.15 with bumblebee and they both have the issue. Whenever the card is started it won’t power down without reboot. I cannot use 310.x or 313.x as they do not support my gt 740m. I bought an nvidia laptop over one with AMD graphics just for nvidia’s reputation of stellar Linux support.
You can see my github posts for additional info: https://github.com/Bumblebee-Project/Bumblebee/issues/153#issuecomment-23066386

I replied on the github thread: does the problem go away if you disable loading the glamoregl module?

Hello. Thanks so much for looking at that. Unfortunately I don’t think it fully worked. There is still something keeping it from unloading from the kernel.

I tried downloading the latest “long lived branch” 319.49.

I added Section

“Module”
Disable “libglamoregl”
EndSection

to the xorg.conf.nvidia file and in the logs it now says

[ 128.186] (WW) “libglamoregl” will not be loaded unless you’ve specified it to be loaded elsewhere.

It doesn’t crash/segfault now (Yay!) but I get this error message in /var/log/messages:

Aug 27 11:18:50 y470c bumblebeed[566]: rmmod: ERROR: Module nvidia is in use
Aug 27 11:18:53 y470c bumblebeed[566]: [ 146.805464] [ERROR]Unloading nvidia driver timed out.

Trying to rmmod the module by hand also fails with the same error messages. “ERROR: Module nvidia is in use”

fuser -v /dev/nvidia*

doesn’t show any output.

I uploaded new logs to:

http://people.engr.ncsu.edu/gsgatlin/issue433/1/nvidia-bug-report.log.gz
http://people.engr.ncsu.edu/gsgatlin/issue433/1/Xorg.8.log
http://people.engr.ncsu.edu/gsgatlin/issue433/1/messages

Please let me know if there is anything else I should try? Thanks again for taking the time to look at this problem.

We’re experiencing the same issue at our lab. Our workflow typically consists of developing CUDA on our laptops, and then deploying to servers for the larger calculations.

Is there anything I could do to help get this working again? The bumblebee-rpm + cuda really made life a lot easier for us, so it’s quite annoying when it’s not working.

It affects other distros as well. I have the same issue with opensuse 12.3 64 bit, 3.11.0 kernel, nvidia 325.15, bumblebee 3.2.1, bbswitch 0.7.

May I ask, why use bumblebee If nvidia now supports Optimus in driver 319 and higher?

Or is nvidia Optimus in Linux not yet fully supported and bumblebee is still the better choice for near Windows level Optimus functionality?

virtualeyes, see:

https://plus.google.com/102207276811032054708/posts/8bAKax1PJoi

Short answer is that it is not yet fully supported. It helps with external monitors in some cases with certain laptops but not in displaying nvidia graphics on the intel integrated GPU X session which is usually the main laptop display screen. That won’t be “officially supported” AFAIK until and unless the nvidia module works with PRIME technology in newer versions of X and newer kernels.

Some laptops, like my lenovo y470 it doesn’t help. Because all my DisplayPorts are connected to the intel GPU. But some laptop makers do it differently, and wire the main display to the intel gpu and the HDMI port to the nvidia chip, etc. For those people 319+ will help with the HDMI if they can figure out how to run another X session on there. ( This will make that easier/nicer http://www.phoronix.com/scan.php?page=news_item&px=MTQ1MDc )

So until the technology is more officially supported all we have is bumblebee to fall back on. Which is why I opened this thread. I get around 60fps in minecraft with bumblebee/primus vs 20 fps with the intel GPU. So bumblebee is a technology I use almost every day when I am on the go with my optimus laptop.

Hope that helps to explain the current situation. Cheers,

Hi All, Please don’t forget to add system information by running nvidia-bug-report.sh as root user to we can duplicate this issue inhouse for investigation. We need this to match hardware.

I can reproduce this issue on an Asus N56VZ running Fedora 19. The relevant system information is: https://dl.dropboxusercontent.com/u/59800509/nvidia-bug-report.log.gz
nvidia-bug-report.log.gz (114 KB)

I ran nvidia-bug-report.sh three times on my opensuse 12.3 64-bit laptop.

  1. just nvidia-bug-report.sh as root.(it failed)

  2. Started something that uses nvidia using (“primusrun glxspheres” as normal user) and ran nvidia-bug-report.sh as root again, it completed this time.

  3. ran “primusrun nvidia-bug-report.sh” as root (it said it completed)

I have attached the link for all three runs with the console output:

https://dl.dropboxusercontent.com/u/12204186/console-out.txt
https://dl.dropboxusercontent.com/u/12204186/001-nvidia-bug-report.log.old.gz
https://dl.dropboxusercontent.com/u/12204186/002-nvidia-bug-report.log.gz
https://dl.dropboxusercontent.com/u/12204186/003-nvidia-bug-report.log.gz

[This file was removed because it was flagged as potentially malicious] (70.7 KB)
[This file was removed because it was flagged as potentially malicious] (68.6 KB)
003-nvidia-bug-report.log.gz (69.9 KB)
console-out.txt (2.65 KB)

hadrons123, Please provide nvidia bug report and steps that hit this issue.

dubiousphysics, Did you also observing exact same issue or bit different ?

I reproduced the same issues as gsgatlin, with the xorg-xserver crashing after running bumblebee.
Here are the bug report logs as well as the corresponding terminal log.
I’m running Fedora 19 and using the 319.49 driver (gsgatlins bumblebee-nvidia rpm).

EDIT: Attached files directly in the forum.
[This file was removed because it was flagged as potentially malicious] (81.4 KB)
[This file was removed because it was flagged as potentially malicious] (98.8 KB)
nvidia-bug-report2.log.gz (83.7 KB)
terminal_log.txt (2.86 KB)

LKlevin, Not able to access https://www.dropbox.com as its internally blocked. Please attach logs to this forum itself.

I am encountering the same issue as the one described in the first post.