Bumblebee issue in fedora 18/19 with nvidia drivers newer than 310.51 and xorg-x11-server-Xorg-1.14

So… I’m feeling a little stupid right now, but how am I supposed to do the attachment?
It seems they’re stuck at “[SCANNING… PLEASE WAIT]”.

Bug 1380042 : Able to repro this issue internally for both FC18 and FC19 - nvidia driver unload issue as well as Xorg seg fault with notebook Lenovo IdeaPad Y580 .

We investigated this issue and found this is not nvidia driver issue.

To expand on that, the issue is that the running X server fails to close the drm device node (/dev/dri/card1) after unsuccessfully attempting to load the modesetting driver:

I am experiancing the same error.

My system specs are:
Linux archlinux 3.13.5-1-ARCH #1 SMP PREEMPT Sun Feb 23 00:25:24 CET 2014 x86_64 GNU/Linux

But I had the same error using Ubuntu 13.10.

My hardware specs: archlinux description: Laptop product: W3x0ET (To be filled by O.E.M.) - Pastebin.com

Installed NVIDIA packages: extra/libcl 1.1-3 [installed] OpenCL library and ICD loader from NVIDIAex - Pastebin.com
(I also downgraded to nvidia-304xx-304.119-1-x86_64.pkg.tar.xz but this did not work either)

Bumblebeed Log: [ 5944.408463] [INFO]bumblebeed 3.2.1 started[ 5953.742232] [WARN][XORG] (WW) - Pastebin.com

After running a script for testing Theano library: http://pastebin.com/q6jW5K8d

Oh sorry, I just saw that this was no NVIDIA Driver issue …