Nvidia 555.58 + 4k@120Hz Causes Flickering & Artifacting on X and Wayland With Arch

I updated Arch and now I can’t use my screen above 60fps when using 4k without horrible artifacts and the screen regularly going black for a second or two. 60fps is stable. I can downgrade using timeshift, but I’d prefer to not have to because I really want to start using Wayland full-time. Right now I can’t use Wayland or X above 60fps since it happens with both whether in a game or not when using GNOME. Haven’t tested any other DE. VRR on with Wayland doesn’t fix it. If I switch back to driver v550, this does not happen with X or Wayland with 4k@120fps.

Only happens with 4k. 2k and 1080p 120fps is stable.

Specs:

  • DE: GNOME 46
  • OS: Arch
  • Card: Nvidia 4090
  • Driver: 555.58
  • CPU: 13900k

Contents of /etc/modprobe.d/nvidia-power-management.conf:

options nvidia_drm modeset=1
options nvidia_drm fbdev=1
options nvidia NVreg_EnableGpuFirmware=0
options nvidia NVreg_PreserveVideoMemoryAllocations=1

I ran sudo mkinitcpio -P after changing it

I also ran nvidia-smi -q | grep GSP after a reboot and confirmed GSP is disabled with the output GSP Firmware Version : N/A

Contents of /boot/loader/entries/arch.conf:

title Arch Linux
linux /vmlinuz-linux
initrd /intel-ucode.img
initrd /initramfs-linux.img
options root="LABEL=/" rw nvidia-drm.modeset=1 nvidia-drm.fbdev=1 nvidia.NVreg_EnableGpuFirmware=0 nvidia.NVreg_PreserveVideoMemoryAllocations=1

I also have the nvidia-resume, nvidia-hibernate, and nvidia-suspend services enabled. When I show the status of all 3 services using sytemctl status, it says they’re all dead? I don’t see any issues in journalctl. Maybe I Just don’t understand how these services are supposed to work.

Even with all that, I had to force enable Wayland via the symlink below

ln -s /dev/null /etc/udev/rules.d/61-gdm.rules

Maybe me having to force enable it is a sign something else is still needs done? Everything worked fine with 550, so maybe not?

1 Like

Same here,

Ryzen 5950X
3080Ti
Arch
KDE
555.58

I had to lower the refresh rate to 60Hz to stop the flickering, it happened in Wayland and X11

1 Like

555.58.02 fixes the issue!

Update: NVM, its better tho

1 Like

I just updated and it unfortunately does not fix the issue for me.

forgot to update here :D, its better tho, but the flickering is there

1 Like

Hi @thewisenoob @emmanuelrobles94
I used below setup locally but could not repro issue so far.
ASRock TRX40 Taichi + AMD 100-000000011-11 + Manjaro Linux 24.0.3 + kernel 6.8.12-3-MANJARO + NVIDIA GeForce RTX 4070 Ti + Driver 555.58.02 + Asus PG38UQ with resolution 3840 x 2160 and refresh rate as 120 Hz or 144 Hz connected via HDMI 2.1 cable + Wayland or X11 + KDE
I ran youtube videos via firefox browser on above setup for almost an hour but could not observe any flickering or artifacts issue. PLease share exact repro steps if possible.
Could you also please share nvidia bug report along with display model and confirm if it’s connected via DP/HDMI so that I can using similar display model locally.

1 Like

@amrits Sorry for not providing all of that info already.

Here is the log:
nvidia-bug-report.log (2.2 MB)

More Specs:

Below is a video demonstrating me switching from 60Hz, which is stable, to 119.88Hz. Video shows the black screens and artifacting. Not sure if artifacting is the right word, but you’ll see what I mean:

I couldn’t upload the video here since it is larger than 100MB.

As I stated before, 119.88Hz is stable with 550 but not 555.58 or 555.58.02. I also probably should have specified the refresh rate is approximately 120Hz, not exactly 120Hz.

I’m not sure if there’s any other details or steps to what I did. The problem happens when doing anything, so running a video or game is unnecessary.

Thanks @thewisenoob for sharing video and other details.
I will try to find Samsung QN75QN85BAFXZA locally and attempt for local repro.
Just wanted to confirm that attached bug report has different display model, did you share correct report with us.

1 Like

@amrits What model does the report say? I couldn’t find where it mentions the model, but I did see it mentions Samsung. I only have one Samsung device, so it must be correct. I copied the model number from the TV’s system settings. I just checked my order on Samsung’s site. It’s called “QN85B Samsung Neo QLED 4K Smart TV” on there. Screenshot below.

Retried repro again with Samsung Neo QLED TV with different desktop environments and display protocols but could not repro issue.

ASRock TRX40 Taichi + AMD 100-000000011-11 + Manjaro Linux 24.0.3 + kernel 6.8.12-3-MANJARO + NVIDIA GeForce RTX NVIDIA GeForce RTX 3080 + Driver 555.58 + Samsung model QA55QN85BAKLXL + Resolution 3840 x 2160 + Refresh rate as 100 and 120 Hz + Gnome DE on X and Wayland

ASRock TRX40 Taichi + AMD 100-000000011-11 + Manjaro Linux 24.0.3 + kernel 6.8.12-3-MANJARO + NVIDIA GeForce RTX NVIDIA GeForce RTX 3080 + Driver 555.58 + Samsung model QA55QN85BAKLXL + Resolution 3840 x 2160 + Refresh rate as 100 and 120 Hz + Plasma DE on X and Wayland

@emmanuelrobles94
Could you also please share nvidia bug report from repro state.

1 Like

@amrits will do, uhmmm,

this is my screen, random question, did you use Hdmi or DP?

nvidia-bug-report.log (7.2 MB)

1 Like

Hmmm that’s unfortunate. Maybe it’s an issue with the kernel? I’m on 6.9 while you’re using 6.8.

1 Like

Any updates ? I am having this issue top . I am using kernel 6.9.9 , but i think is nvidia driver because i tested with LTS kernel too

1 Like

I used HDMI 2.1 cable and retried repro with another display model LG 27GP95R but still no luck in repro.
I will continue to tweak my setup configuration as well as hardware to obtain local repro.

1 Like

Thank you, @amrits 🙏