Nvidia-dkms-460 Error

I am having the same error. I have attatched the bug report. please help
nvidia-bug-report.log (598.3 KB)


Following the suggestion worked.

Thanks for sharing.

Although, then I have to re-install my CUDA libraries again. sigh

Linux version 5.11.0-7614-generic (buildd@lgw01-amd64-025) (gcc (Ubuntu 10.2.0-13ubuntu1)

Kernel was built with gcc 10.

gcc version 9.3.0 (Ubuntu 9.3.0-18ubuntu1)

But you (now) have v. 9.
Guess you set that?
I told you to look at /proc/version.
Check if gcc and g++ v. 10 are installed. And if yes, use update-alternatives.
Purge and reinstall the driver using apt.
You just need to install cuda-toolkit, not complete cuda (which would try to install its own driver when following the nvidia guide).

It was originally set to v10. I saw you changing it to v9 in this thread so I did so. So maybe this isn’t an issue related to gcc as I had this problem before changing the version.

Well, set it back to default.
purge all driver and cuda files.
reinstall the driver from repo and then install cuda-toolkit.