Both NVIDIA Driver 430.x and 440.x fail to DKMS Install on Kernels 5.4.1 and 5.4.2

Seeing the same issue that was reported here:

https://bugzilla.kernel.org/show_bug.cgi?id=205661

Error seen when installing 5.4.x kernel:

Building module:
cleaning build area...
unset ARCH; env NV_VERBOSE=1 'make' -j16 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=5.4.2-050402-generic IGNORE_XEN_PRESENCE=1 IGNORE_CC_MISMATCH=1 SYSSRC=/lib/modules/5.4.2-050402-generic/build LD=/usr/bin/ld.bfd modules....(bad exit status: 2)
ERROR (dkms apport): kernel package linux-headers-5.4.2-050402-generic is not supported
Error! Bad return status for module build on kernel: 5.4.2-050402-generic (x86_64)
Consult /var/lib/dkms/nvidia/440.36/build/make.log for more information.
   ...done.

Error seen in log:DKMS make.log for nvidia-440.36 for kernel 5.4.2-050402-generic (x86_64)

Thu Dec  5 19:17:41 PST 2019
make[1]: Entering directory '/usr/src/linux-headers-5.4.2-050402-generic'
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (		\
echo >&2;							\
echo >&2 "  ERROR: Kernel configuration is invalid.";		\
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";	\
echo >&2 ;							\
/bin/false)

The files autoconf.h and auto.conf appear to exist in 5.4.2 directory. Here is summary of all the 'Error’s that occurred.

cat /var/lib/dkms/nvidia/440.36/build/make.log | egrep “Error”

make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-frontend.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-i2c.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-pci.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-cray.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-usermap.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-dma.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-mempool.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-vtophys.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-mmap.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-procfs.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-pat.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-p2p.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/os-interface.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-acpi.o] Error 1
make[2]: *** [/var/lib/dkms/nvidia/440.36/build/nvidia/nv-vm.o] Error 1
make[1]: *** [/var/lib/dkms/nvidia/440.36/build] Error 2
make: *** [modules] Error 2

Drivers work just fine on kernels 4.3.10 and 4.3.15 , guessing no issues with 4.3.x.

I can’t confirm your problem here (Debian Sid / siduction).

~
towo:OMPC-AV2> sudo dkms status
nvidia-current, 440.36, 5.3.12-towo.2-siduction-amd64, x86_64: installed
nvidia-current, 440.36, 5.3.13-towo.1-siduction-amd64, x86_64: installed
nvidia-current, 440.36, 5.3.14-towo.1-siduction-amd64, x86_64: installed
nvidia-current, 440.36, 5.4.2-towo.1-siduction-amd64, x86_64: installed

Builds and working fine.

I’m running vanilla 5.4.2 and it works for me.

$ uname -a
Linux zen 5.4.2-az2 #1 SMP PREEMPT Thu Dec 5 16:41:53 2019 x86_64 x86_64 x86_64 GNU/Linux

$ modinfo nvidia | grep version
version:        440.36

Looks like this was resolved in 5.4.3.

Thanks everybody.

Reference: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-440/+bug/1855590

I’m currently running 5.3.15-050315-generic , will try updating shortly to 5.4.3 to confirm it resolves my issue.

Unfortunately, that did not work for me.

OS: Ubuntu 18.04.3 LTS x86_64
Video Card: GeForce RTX 2080 Ti

Im currently running 5.3.15-050315-generic and nvidia driver is seen and loads fine:

lspci | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1e04 (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 10f7 (rev a1)
01:00.2 USB controller: NVIDIA Corporation Device 1ad6 (rev a1)
01:00.3 Serial bus controller [0c80]: NVIDIA Corporation Device 1ad7 (rev a1)

lsmod | grep -i nvida
nvidia_uvm 929792 0
nvidia_drm 49152 7
nvidia_modeset 1114112 15 nvidia_drm
nvidia 20402176 763 nvidia_uvm,nvidia_modeset
drm_kms_helper 184320 1 nvidia_drm
drm 491520 10 drm_kms_helper,nvidia_drm
ipmi_msghandler 102400 2 ipmi_devintf,nvidia
i2c_nvidia_gpu 16384 0

How can I run build/install nvidia kernel module manually on 5.4.x?
What information can I post here that would be useful?

Thanks again for all the help.

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

1 Like

Attached nvidia-bug-report.log.gz to my last post.

same issue with the latest Kernel 5.4.6.
I’am currently running Kernel 5.3.2 without problems.

You’re running a kernel compiled with gcc 9.2.1 but the system compiler is set to gcc 7.4.0. If you want to keep the current kernel, please switch to the corresponding gcc.

1 Like

so, i installed gcc version 9.2.1 and it’s running :)
Thx for helping me! Have good days and a nice new year.

Installing gcc 9.2.1 also solved it for me. Thank you and happy new year.

Exactly the same problem I faced last 3 days but not succeed. I have server machine with Ubuntu 18.04 with Telsa K80, and want to install Driver Version: 440.82 but facing this error :

ERROR (dkms apport): kernel package linux-headers-5.4.9-050409-generic is not supported

compile using gcc 6

But When I install driver using sudo apt install nvidia-driver-440 with gcc 9.3 I resolved the problem

Make sure to reboot machine after driver installation

Thanks @generix