Problems getting NVIDIA drivers installed and GEFORCE RTX 2070 Super cards to be recognized

Hi,
I have two RTX 2070 Supers installed on a supermicro board with onboard graphics. I initially had Ubuntu 18.04 installed but had issues getting the drivers that came along with Ubuntu to work with the cards (nvidia-smi would show the cards but no processes were active and I was unable to use the cards for other purposes). I tried installing the drivers that came along with Ubuntu as well as downloading the 440.run file from NVIDIA directly. Nothing worked.

I gave up with Ubuntu 18.04 and tried updating to 19.04, hoping this would fix the issues. I am still getting errors, just different ones. By downloading “NVIDIA-Linux-x86_64-440.36.run” from NVIDIA, making it executable, and then running “sudo bash NVIDIA…” I get the following errors:

Building for 5.4.2-050402-generic
Building for architecture x86_64
Building initial module for 5.4.2-050402-generic
ERROR (dkms apport): kernel package linux-headers-5.4.2-050402-generic is not supported
Error! Bad return status for module build on kernel: 5.4.2-050402-generic (x86_64)
Consult /var/lib/dkms/nvidia/440.26/build/make.log for more information.
dpkg: error processing package nvidia-dkms-440 (–configure):
installed nvidia-dkms-440 package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of nvidia-driver-440:
nvidia-driver-440 depends on nvidia-dkms-440 (= 440.26-0ubuntu0~gpu19.04.2); however:
Package nvidia-dkms-440 is not configured yet.

dpkg: error processing package nvidia-driver-440 (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Processing triggers for initramfs-tools (0.131ubuntu19.2) …
update-initramfs: Generating /boot/initrd.img-5.4.2-050402-generic
Errors were encountered while processing:
nvidia-dkms-440
nvidia-driver-440
E: Sub-process /usr/bin/dpkg returned an error code (1)

The DKMS make log has this to say:
KMS make.log for nvidia-440.26 for kernel 5.4.2-050402-generic (x86_64)
Tue 10 Dec 2019 12:54:44 PM EST
make[1]: Entering directory ‘/usr/src/linux-headers-5.4.2-050402-generic’
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (
echo >&2;
echo >&2 " ERROR: Kernel configuration is invalid.";
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";
echo >&2 " Run ‘make oldconfig && make prepare’ on kernel src to fix it.";
echo >&2 ;
/bin/false)
make -f ./scripts/Makefile.build obj=/var/lib/dkms/nvidia/440.26/build single-build= need-builtin=1 need-modorder=1
ln -sf /var/lib/dkms/nvidia/440.26/build/nvidia/nv-kernel.o_binary /var/lib/dkms/nvidia/440.26/build/nvidia/nv-kernel.o
ln -sf /var/lib/dkms/nvidia/440.26/build/nvidia-modeset/nv-modeset-kernel.o_binary /var/lib/dkms/nvidia/440.26/build/nvidia-modeset/nv-modeset-kernel.o
{ echo /var/lib/dkms/nvidia/440.26/build/nvidia.ko; echo /var/lib/dkms/nvidia/440.26/build/nvidia-uvm.ko; echo /var/lib/dkms/nvidia/440.26/build/nvidia-modeset.ko; echo /var/lib/dkms/nvidia/440.26/build/nvidia-drm.ko; :; }
| awk ‘!x[$0]++’ - > /var/lib/dkms/nvidia/440.26/build/modules.order
The Module.symvers file is missing, or does not contain any
symbols exported from the kernel. This could cause the NVIDIA
kernel modules to be built against a configuration that does
not accurately reflect the actual target kernel.
The Module.symvers file check can be disabled by setting the
environment variable IGNORE_MISSING_MODULE_SYMVERS to 1.
make[2]: *** [/var/lib/dkms/nvidia/440.26/build/Kbuild:186: module_symvers_sanity_check] Error 1
make[2]: *** Waiting for unfinished jobs…
make[1]: *** [Makefile:1652: /var/lib/dkms/nvidia/440.26/build] Error 2
make[1]: Leaving directory ‘/usr/src/linux-headers-5.4.2-050402-generic’
make: *** [Makefile:81: modules] Error 2

Does anyone have any thoughts???
nvidia-bug-report.log (644 KB)

Running a 5.4 kernel requires a newer driver than 440.26. The 19.10 stock kernel should be 5.3.