Nvidia GeForce GT 560M + multimonitor, two grey screen

Hi,
I have tried to configure multimonitor with nvidia settings
I have two monitor ASUS 299MX, connected to a laptop.
With nvidia settings, one of the monitor remains in black
So i tried to dig up xorg.conf
The two monitors, this times get activated, the mouse is functionning
on both, but the monitors remain in grey with nologin prompt.
Here is my xorg.conf
I’m running centos 7
Kernel is 3.10.0-957.21.3.el7.x86_64
The nvidia driver has been installed with NVIDIA-Linux-x86_64-390.87.run
Any help would be apprieciated

Mfg
jdum

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 390.87 (buildmeister@swio-display-x64-rhel04-14) Tue Aug 21 17:32:26 PDT 2018

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 390.87 (buildmeister@swio-display-x64-rhel04-14) Tue Aug 21 17:33:38 PDT 2018

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
Screen 1 “Screen1” RightOf “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “on”
EndSection

Section “Files”
FontPath “/usr/share/fonts/default/Type1”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/input/mice"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Ancor Communications Inc ASUS MX299”
HorizSync 26.0 - 83.0
VertRefresh 24.0 - 76.0
Option “DPMS”
EndSection

Section “Monitor”
Identifier “Monitor1”
VendorName “Unknown”
ModelName “Ancor Communications Inc ASUS MX299”
HorizSync 26.0 - 83.0
VertRefresh 24.0 - 76.0
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTX 560M”
BusID “PCI:1:0:0”
Screen 0
Option “TwinView” “true”
Option “RenderAccel” “true”
Option “UseEdidFreqs” “true”
Option “MetaModes” “2560x1080,1600x1200,1600x1200;1280x1024”
EndSection

Section “Device”
Identifier “Device1”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTX 560M”
BusID “PCI:1:0:0”
Screen 1
Option “TwinView” “true”
Option “MetaModes” “2560x1080,1600x1200,1600x1200;1280x1024”
EndSection

Section “Screen”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-2"
Option         "metamodes" "DVI-I-1: nvidia-auto-select +0+0"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
Modes      "5120x2160" "3200x1200" "2560x1024" "1024x768" "1600x600" "1280x480"
EndSubSection

EndSection

Section “Screen”
Identifier “Screen1”
Device “Device1”
Monitor “Monitor1”
DefaultDepth 24
Option “Stereo” “0”
Option “metamodes” “HDMI-0: nvidia-auto-select +0+0 {AllowGSYNC=Off}”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
SubSection “Display”
Depth 24
EndSubSection
EndSection

nvidia-bug-report.log.gz (115 KB)

You have set up two separate screens, so what you see is expected. Please delete your xorg.conf, reboot, log in, run
xrandr --auto
then please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hi
;conf
I removed the last screen section in xorg.conf and gdm
does not not start
Mfg
Jacques

According to the logs, the xserver comes up fine without an xorg.conf, there’s just a message that the EDID can’t be read on HDMI-0.
What’s the current state?

Should i try
nvidia-bug-report.sh
with my settings ?

btw: I got it working once, but did not saved the xorg.conf, then i disconnected the hdmi and dvi
cable to switch monitors, still then only one monitor is active.
mfg
Jacques

The log you attached told me taht you deleted the xorg.conf and all monitors were detected fine, so I don’t know what you experienced.
Please use this as xorg.conf:

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"
    Option         "AllowEmptyInitialConfiguration"
EndSection

afterwards, please create a new nvidia-bug-report.log and describe what you see.