NVIDIA Jetson Nano B01 – IMX290 not working

Hi! I am working with the Jetson Nano Board and the Sony IMX290 (MIPI-CSI2) 2-lane camera and I have modified the device driver according to the “Driver Programming Guide”, the file is attached bellow. The camera is connected to CSI_C and I can detect /dev/video0 entry, also when I run:

$ v4l2-ctl –list-devices

I can see that the port bindings are correct. But, when I try to test the camera and take an image with the command:

$ v4l2-ctl -d /dev/video0 --set-fmt-video=width=1920,height=1080,pixelformat='Y10 ' --set-ctrl bypass_mode=0 --stream-mmap --stream-count=1 --stream-to=-test.raw

The camera is stuck in a loop and the .raw file is empty. In the dmesg log I get this output:

[  247.045714] vi 54080000.vi: TEGRA_CSI_PIXEL_PARSER_STATUS 0x00004000
[  247.052931] vi 54080000.vi: TEGRA_CSI_CIL_STATUS 0x00000012
[  247.058639] vi 54080000.vi: TEGRA_CSI_CILX_STATUS 0x00060060
[  247.064733] video4linux video0: tegra_channel_capture_setup(): valid_ports=1: width,height=1920,1080 word_count=2400

What I got from reading the CSI registers in the TRM manual it seems that the start sequence is not correct, but when I look at the start sequence on an oscilloscope it looks like the sequence stated in the camera manual.

Also, when I run the v42l-compliance test I get some errors, but I am not sure what they mean.

v4l2-compliance SHA   : not available

Driver Info:
        Driver name   : tegra-video
        Card type     : vi-output, imx290 7-001a
        Bus info      : platform:54080000.vi:2
        Driver version: 4.9.140
        Capabilities  : 0x84200001
                Video Capture
                Extended Pix Format
                Device Capabilities
        Device Caps   : 0x04200001
                Video Capture
                Extended Pix Format

Compliance test for device /dev/video0 (not using libv4l2):

Required ioctls:
        test VIDIOC_QUERYCAP: OK

Allow for multiple opens:
        test second video open: OK
        test VIDIOC_QUERYCAP: OK
        test VIDIOC_G/S_PRIORITY: OK
        test for unlimited opens: OK

Debug ioctls:
        test VIDIOC_DBG_G/S_REGISTER: OK (Not Supported)
        test VIDIOC_LOG_STATUS: OK

Input ioctls:
        test VIDIOC_G/S_TUNER/ENUM_FREQ_BANDS: OK (Not Supported)
        test VIDIOC_G/S_FREQUENCY: OK (Not Supported)
        test VIDIOC_S_HW_FREQ_SEEK: OK (Not Supported)
        test VIDIOC_ENUMAUDIO: OK (Not Supported)
        test VIDIOC_G/S_AUDIO: OK (Not Supported)
        Inputs: 1 Audio Inputs: 0 Tuners: 0

Output ioctls:
        test VIDIOC_G/S_MODULATOR: OK (Not Supported)
        test VIDIOC_G/S_FREQUENCY: OK (Not Supported)
        test VIDIOC_ENUMAUDOUT: OK (Not Supported)
        test VIDIOC_G/S/ENUMOUTPUT: OK (Not Supported)
        test VIDIOC_G/S_AUDOUT: OK (Not Supported)
        Outputs: 0 Audio Outputs: 0 Modulators: 0

Input/Output configuration ioctls:
        test VIDIOC_ENUM/G/S/QUERY_STD: OK (Not Supported)
        test VIDIOC_ENUM/G/S/QUERY_DV_TIMINGS: OK (Not Supported)
        test VIDIOC_DV_TIMINGS_CAP: OK (Not Supported)
        test VIDIOC_G/S_EDID: OK (Not Supported)

Test input 0:

        Control ioctls:
                test VIDIOC_QUERYCTRL: OK
                test VIDIOC_G/S_CTRL: OK
                test VIDIOC_G/S/TRY_EXT_CTRLS: OK
                test VIDIOC_G/S_JPEGCOMP: OK (Not Supported)
                Standard Controls: 1 Private Controls: 16

        Format ioctls:
                fail: v4l2-test-formats.cpp(1184): ret && node->has_frmintervals
                test VIDIOC_G/S_PARM: FAIL
                test VIDIOC_G_FBUF: OK (Not Supported)
                fail: v4l2-test-formats.cpp(434): pixelformat 20303159 (Y10 ) for buftype 1 not reported by ENUM_FMT
                test VIDIOC_G_FMT: FAIL
                test VIDIOC_TRY_FMT: OK (Not Supported)
                test VIDIOC_S_FMT: OK (Not Supported)
                test VIDIOC_G_SLICED_VBI_CAP: OK (Not Supported)
                test Cropping: OK (Not Supported)
                test Composing: OK (Not Supported)
                test Scaling: OK (Not Supported)

        Codec ioctls:
                test VIDIOC_(TRY_)ENCODER_CMD: OK (Not Supported)
                test VIDIOC_G_ENC_INDEX: OK (Not Supported)
                test VIDIOC_(TRY_)DECODER_CMD: OK (Not Supported)

        Buffer ioctls:
                fail: v4l2-test-buffers.cpp(574): VIDIOC_EXPBUF is supported, but the V4L2_MEMORY_MMAP support is missing, probably due to earlier failing format tests.
                test VIDIOC_EXPBUF: OK (Not Supported)

Test input 0:

Total: 43, Succeeded: 41, Failed: 2, Warnings: 0

imx290.c (68.1 KB)
imx290.dtsi (19.5 KB)

Any ideas what could be wrong?
Thank you in advance!

You may need to check the MIPI signal match the spec.
Also does Nano support Y12 format?

I don’t know, where can I check that?

Check TRM for the format support in VI(video input) chapter.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.