NVIDIA Jetson Xavier NX boot fail

Hi, I’m using the NVIDIA Jetson Xavier NX since 3 weeks and everything was working on it. But now it’s the second time in less than 1 week that the Jetson shutdown and when it restart everything on the SD card is erased. I flashed again my SD card and then tried to run it but the boot failed.

I followed the Getting started with Jetson Xavier NX Developer Kit and reflashed my SD card and now I’m getting this message error at the end of the flash

Do you have an idea of how to solve this problem?


A serial console boot log would probably help, but this looks a lot like the SD card has issues (a failing SD card can behave exactly like this). Do you have any other SD cards around you could test with?

Yes, it looks like the file system over the SD is broken. Or the sdcard itself is broken.

Yes thanks, the sd card was the problem. Here the specs of the sd card I was using

I’m currently using this sd card

I wanted to know if is it possible to give me the specs of the best sdcard I could use to run the Jetson Xavier NX perfectly

I’m pretty sure those specs are fine (I couldn’t give you any specific spec), but SD cards often have different levels of quality. Some work for some purposes, yet fail for others. SD cards also often fail after they worked for some time. I am certain that the UHS-I is itself quite well supported.

Thanks for your help

Please I really need help,i have the issues on my Jetson NX I have tried different SD cards with successful image flashing but still giving me the same output… I used the same SD card on my Jetson nano they are working fine

I’m thinking I saw this somewhere else…best to avoid multiple postings (not sure if that is the case here though). FYI, “Inappropriate ioctl for device” implies that either (A) the wrong driver is being used for the device, or (B) an attempt to use a feature via the driver has failed because the driver is not the one the ioctl is for. All of this shows up when trying to work with an imx219 camera, which I know nothing about.

Are your NX flash attempts using the SDK Manager to flash the board itself with the same release which has created the SD card? The NX has QSPI memory with boot content, and the boot content changes depending on release. If the NX itself were not flashed with the correct release of boot software on QSPI (versus the SD card), then it will fail. Have you flashed and created your SD card from the same release?