Nvidia-smi shows "No devices were found", and dmesg shows "rm_init_adapter failed, device minor number 0"

After upgrade nvidia driver from 460 to 470, linux kernel from 5.4 to 5.13, my RTX3090 is not working. I tried to reinstall OS, drivers, all of them are not working. What should I do then? I attach my nvidia-bug-report file and hope it can help.
nvidia-bug-report.log.gz (147.3 KB)

You’re running pass-through on vmware, please see this thread:

Hi generix, thanks for your reply.

I’ve seen this thread before and still focus on it. I also think this problem is caused by the hypervisor. Should I make a bare metal system to confirm the GPU has not physical failures?

I guess so. Looks like passthrough on esxi doesn’t work with drivers >470.

Hi generix, Glad to tell you I solved this problem by using a low version driver. Fixing procedure recorded in Nvidia-smi "No devices were found" - VMWare ESXI Ubuntu Server 20.04.03 with RTX3070 - #23 by DPCFish

Thanks for your help! <3

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.