Ubuntu 20.04 nvidia-smi "No devices were found" at X830 Board with RTX3050Ti Laptop

X830-20.04-nvidia-bug-report.zip (243.1 KB)
X830-22.04nvidia-bug-report.zip (175.1 KB)

Hello , I have been struggling with nvidia driver
Board name : X830
GPU : RTX3050Ti Laptop
OS : Ubuntu 20.04(5.15.0-67-generic)
I tested non-open 515 525 470 drivers but all failed (No devices were found)
I tested same drivers at Ubuntu 22.04 (5.19.0-35-generic) → all failed

I also checked it works at the window OS

I saw

which driver should I use??? @generix

please help …

RmInitAdapter failed! (0x26:0x56:1469)
Bios issue. Please check the board manufacturer’r support for an update.
For a workaround, you can switch to the “-open” driver version in Software&Updates and set kernel parameter

thank you for reply!

Were you saying that I need to request the board manufacturer to solve the issue?
How to set kernel parameter?

    modprobe nvidia NVreg_OpenRmEnableUnsupportedGpus=1
or, in an /etc/modprobe.d/ configuration file:
    options nvidia NVreg_OpenRmEnableUnsupportedGpus=1

is it right ?


and run
sudo update-initramfs -u
Though your system seems to be some kind of mini-desktop resembling more a laptop, so the open driver isn’t really recommended.

1 Like

As you said, it’s a mini-PC. Is there any other way other than updating the bios?

I don’t understand exactly which layer is causing the problem.

I’m assuming it’s a bios issue.

What part of the bios is the problem?

thanks a lot !!!
it works when I change 525-open driver after setting kernel param

1 Like

Good question, IDK. Affected are only Turing and newer gpus, only Geforce types. Happening with eGPUs, passthrough on exsi and rarely on plain simple mainboards. Started with driver 470.
One affected mainboard actually got a bios update which fixed it.

Thanks it helped

In addition, you need to add the file of the following content to /etc/modprobe.d/

File name: nvreg_fix.conf
Content: options nvidia NVreg_OpenRmEnableUnsupportedGpus=1

Or command: echo "options nvidia NVreg_OpenRmEnableUnsupportedGpus=1" | sudo tee /etc/modprobe.d/nvreg_fix.conf > /dev/null

sudo update-initramfs -u 

Set 525 driver:


1 Like