Ubuntu 20.04 nvidia-smi “No devices were found”

Hi there,

I am aware that this is not the first topic within this field, but none of the other topics seems to have fixed my issue. So trying my luck with my own topic.

I run a docker setup where the Nvidia card is required to transcode files into another file type.

Yesterday I swapped out a GTX 1060 to a RTX 2070 Super and after that, it is not being detected by Nvidia-smi. It just states “No devices were found”

When checking with lspci | egrep 'VGA|3D' i t shows:

00:0f.0 VGA compatible controller: VMware SVGA II Adapter
03:00.0 VGA compatible controller: NVIDIA Corporation TU104 [GeForce RTX 2070 SUPER] (rev a1)

dkms status nvidia command states:
nvidia, 470.182.03, 5.4.0-147-generic, x86_64: installed
nvidia, 470.182.03, 5.4.0-148-generic, x86_64: installed

(Booting on 5.4.0-147)

Tried reinstalling drivers, and updating to newer drivers which gave me errors regarding Nvidia-smi not not being able to “contact the driver”.
However, that is fixed for now. So currently back on the same driver that worked for my GTX 1060

The last time installing the drivers I went through these commands and only installed these packages which worked:

distribution=$(. /etc/os-release;echo $ID$VERSION_ID) \
   && curl -s -L https://nvidia.github.io/nvidia-docker/gpgkey | sudo apt-key add - \
   && curl -s -L https://nvidia.github.io/nvidia-docker/$distribution/nvidia-docker.list | sudo tee /etc/apt/sources.list.d/nvidia-docker.list

sudo apt update && sudo apt install apt-transport-https ca-certificates curl gnupg lsb-release

sudo apt update && sudo apt install --no-install-recommends nvidia-headless-465 nvidia-utils-465 libnvidia-encode-465 nvidia-container-toolkit nvidia-docker2

I tried some different things including: options nvidia NVreg_OpenRmEnableUnsupportedGpus=1 in nvidia.conf in /etc/modprobe.d
And sudo ubuntu-devices autoinstall (which turned out to be a bad idea as I suddenly got a GUI and loads of stuff installed…)

Hoping for a hero or two that can help.

I’ve attached the Nvidia bug report.
nvidia-bug-report.log (2.5 MB)

Edit: It is a VM running on ESXI 6.7 with GPU Passthrough.