No device detected ; Ubuntu 20.04

I have an Ubuntu (20.04) VM which has been working perfectly well for a year. Recently, for whatever reason the 1650 Super is no longer being detected by the VM.

When I run nvidia-smi, I get the following

jay@mediapc:~$ nvidia-smi
No devices were found

I’ve tried rebuilding a new VM with the following commands

sudo ubuntu-drivers autoinstall

And I still get No devices were found, when running nvidia-smi

This is what I get when I run ubuntu-drivers devices

jay@mediapc:~$ ubuntu-drivers devices
ERROR:root:could not open aplay -l
Traceback (most recent call last):
  File "/usr/share/ubuntu-drivers-common/detect/", line 35, in detect
    aplay = subprocess.Popen(
  File "/usr/lib/python3.8/", line 858, in __init__
    self._execute_child(args, executable, preexec_fn, close_fds,
  File "/usr/lib/python3.8/", line 1704, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'aplay'
== /sys/devices/pci0000:00/0000:00:0f.0 ==
modalias : pci:v000015ADd00000405sv000015ADsd00000405bc03sc00i00
vendor   : VMware
model    : SVGA II Adapter
driver   : open-vm-tools-desktop - distro free

== /sys/devices/pci0000:00/0000:00:15.0/0000:03:00.0 ==
modalias : pci:v000010DEd00002187sv00003842sd00001357bc03sc00i00
vendor   : NVIDIA Corporation
model    : TU116 [GeForce GTX 1650 SUPER]
driver   : nvidia-driver-450-server - distro non-free
driver   : nvidia-driver-460-server - distro non-free
driver   : nvidia-driver-460 - distro non-free
driver   : nvidia-driver-495 - distro non-free
driver   : nvidia-driver-470 - distro non-free recommended
driver   : nvidia-driver-470-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

What’s weird is, when I switch my VM to use another GPU (970), nvidia-smi does show results.

So, thinking that this is a GPU issue, I tried to use that GPU in a Windows machine but the Windows machine is able to detect and use the 1650 Super GPU perfectly fine.

Any ideas on how I can fix the issue?

nvidia-bug-report.log.gz (314.6 KB)

The logs show a msi notebook with a rtx2060 which is working fine. Did you attach the wrong file?

I am not sure what happened there, but try this one:

nvidia-bug-report.log.gz (179.0 KB)

Those are the correct logs.
It seems an update of the driver (470.82->470.86) triggered this. Before driver 465, the hypervisor had to be hidden for consumer graphics cards, now this (should) work without it. I suspect this has broken in the 470.86 driver. Please try upgrading the driver to either v495 or to v470.94.