Nvidia-smi shows "No devices were found" on ubuntu server 22.04 LTS with RTX3060

I’ve tried many ways to install the driver of RTX3060 on the ubuntu server 22.04 LTS (Actually a dual OS computer with Windows 10), and met some troubles.
At first, I tried to install it with the recommented version from the default source of ubuntu, however when run “nvidia-smi” it shows “No devices were found”;
Secondly, I tried to uninstall (with apt uninstall) and reinstall it with the .run file from nvidia’s official website, and it returns “lib/driver version are not match” when run “nvidia-smi”.
Thirdly, considering about maybe I had not uninstalled the previous driver completely, I tried uninstall it deeply (with “sudo apt purge nvidia-*” and autoremove) and reinstall it again (with .run file), but it was still not work.
Fourthly, I tried reinstall it with PPA source, and “No devices were found” again.
Fifthly, which is the latest attempt, I redownloaded the .run file (NVIDIA-Linux-x86_64-550.67.run) with the latest version and installed it, still with “No devices were found”.

The order above may have some mistakes because of too many attempts, however, I indeed tried the above ways. And here are other informations maybe helpful:

~$ uname -a
Linux agiserver 5.15.0-97-generic #107-Ubuntu SMP Wed Feb 7 13:26:48 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux

~$ lspci | grep -i nvidia
03:00.0 VGA compatible controller: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] (rev a1)
03:00.1 Audio device: NVIDIA Corporation GA106 High Definition Audio Controller (rev a1)

~$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  550.67  Tue Mar 12 23:54:15 UTC 2024
GCC version:  gcc version 11.4.0 (Ubuntu 11.4.0-1ubuntu1~22.04)

Here is the bug report file:
nvidia-bug-report.log (724.4 KB)
I also find nvidia-installer.log
nvidia-installer.log (41.7 KB)
, nvidia-uninstall.log
nvidia-uninstall.log (1.3 KB)
and cuda-installer.log
cuda-installer.log (180 Bytes)
(I tried to install cuda after the first or second attempt of driver installation, but it had been uninstalled before the next attempt).

I wonder how to make it work well?
I’m appreciate for anyone’s generous help.

1 Like

RmInitAdapter failed! (0x26:0x56:1598)
Shouldn’t happen, the nvidia driver doesn’t like your bios. For a workaround, please switch to the nvidia-open driver.