NVRM: failed to copy vbios to system memory.

Currently I receive the following problem. The machine was running fine before :

NVRM: loading NVIDIA UNIX x86_64 Kernel Module  387.34  Tue Nov 21 03:09:00 PST 2017 (using threaded interrupts)
[  114.134140] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  387.34  Tue Nov 21 02:09:45 PST 2017
[  114.145653] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[  114.145656] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
[  114.172924] nvidia-uvm: Loaded the UVM driver in 8 mode, major device number 241
[  114.726480] r8169 0000:03:00.1 enp3s0f1: link up
[  114.726489] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0f1: link becomes ready
[  115.758990] NVRM: failed to copy vbios to system memory.
[  115.759241] NVRM: RmInitAdapter failed! (0x30:0xffff:662)
[  115.759264] NVRM: rm_init_adapter failed for device bearing minor number 0

The module is loaded but X or bumblebee wont start.

michael@p505:~$ modinfo nvidia_387
filename:       /lib/modules/4.14.14-041414-generic/updates/dkms/nvidia_387.ko
alias:          char-major-195-*
version:        387.34
supported:      external
license:        NVIDIA
srcversion:     EBF1F3E36DFB3BFB97BB385
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
name:           nvidia
vermagic:       4.14.14-041414-generic SMP mod_unload 
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_UpdateMemoryTypes:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_CheckPCIConfigSpace:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_UseThreadedInterrupts:int
parm:           NVreg_EnableStreamMemOPs:int
parm:           NVreg_EnableBacklightHandler:int
parm:           NVreg_EnableUserNUMAManagement:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RegistryDwordsPerDevice:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_AssignGpus:charp

The following card is installed

michael@p505:~$ lspci | grep NVIDIA
01:00.0 3D controller: NVIDIA Corporation GM204M [GeForce GTX 970M] (rev ff)

There is some weird output in /proc

michael@p505:~$ cat /proc/driver/nvidia/gpus/0000\:01\:00.0/information
Model:           GeForce GTX 970M
IRQ:             35
GPU UUID:        GPU-????????-????-????-????-????????????
Video BIOS:      ??.??.??.??.??
Bus Type:        PCIe
DMA Size:        40 bits
DMA Mask:        0xffffffffff
Bus Location:    0000:01:00.0
Device Minor:    0

This error is similar to https://devtalk.nvidia.com/default/topic/1001941/-quot-rminitadapter-failed-quot-with-378-13/

But there is no further reply to this. Please help

nvidia-bug-report.log.gz (68.6 KB)

Please check if kernel parameter
acpi_osi=! acpi_osi=“Windows 2009”

Tried that still the same result. What wonders me that it was working perfect since a mid december upgrade. Unfortunatly I cannot restore the config for that date

Maybe your VBios got corrupted. To check, please switch to nouveau, uninstall nvidia drivers and use kernel parameters
Reboot and attach your dmesg output to your post.

Did you check with drivers 384 or 390, for an easy part?

Another idea: seems like Ubuntu reenabled the intel-spi drivers, maybe blacklist them in /etc/modprobe.d/blacklist.conf
blacklist intel-spi
blacklist intel-spi-platform

I am using 387. The following CMDLINE is used

$ more cmdline
BOOT_IMAGE=/vmlinuz-4.14.14-041414-generic root=/dev/mapper/kubuntu--vg-root ro quiet splash nouveau.debug=debug,VBIOS=trace vt.handoff=7

It is still not working and the intel-spi is not blacklisted but I have tested it before with no result.

Attached it the result of dmesg.

Kind regards for any help

dmesg.log (76.6 KB)

please try again with “acpi_enforce_resources=lax” added to the kernel commandline.

I have the exact same problem with a Tesla K20 that suddently stopped working after an update which cannot be rolled back for other reasons.

We run the Arch distribution.

lspci detects the K20. Nouveau drivers have been black listed and confirmed not loaded.

Using 387.34.

All kernel options aforementioned did not work.

Please check with current driver 390.25

Thanks for your suggestion. I installed 390.25 via Nvidia’s shell script.

I still have the same issue.

[ 2.628671] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 390.25 Wed Jan 24 20:02:43 PST 2018

[ 14.985518] NVRM: failed to copy vbios to system memory.
[ 14.985620] NVRM: RmInitAdapter failed! (0x30:0xffff:662)
[ 14.985667] NVRM: rm_init_adapter failed for device bearing minor number 0

What kernel are you using? Tried downgrading to 4.9?

I have tried every option mentioned so far. No luck. Right now I am running on 4.15 and 390.25. Same result

cat /proc/driver/nvidia/gpus/0000\:01\:00.0/information
Model:           GeForce GTX 970M
IRQ:             35
GPU UUID:        GPU-????????-????-????-????-????????????
Video BIOS:      ??.??.??.??.??
Bus Type:        PCIe
DMA Size:        40 bits
DMA Mask:        0xffffffffff
Bus Location:    0000:01:00.0
Device Minor:    0

As a last resort I will reinstall 17.10.1 now.

I have installed a new BIOS/EC and reinstalled Ubuntu 17.10.1. Still the same Problem. Now I will install Windooze to check if the diskrete Adapter is defect

I have checked the laptop with windows. The card is deactivated there also. Error 43 I assume it is defect. This seems to be quite common for laptop cards as the internet is full with threads concerning faulty GPUs

Same problem here, except it’s a HP Z820 workstation with NVIDIA Quadro K2000 video. Is this a kernel ACPI issue still? This is very frustrating. I’m stuck with Nouveau, which really doesn’t cut it.

mikefl4op8, no acpi error, either broken gpu or kernel problems, maybe related to preemption. Please run nvidia-bug-report.sh as root and attach the resulting tar.gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

Thanks so much for the help! So, bear with me here … I’ve got a Dell workstation at work that runs perfectly with a Quadro K600, so I brought my K2000 in from home, plugged it in and rebooted and have the same problem … failed to copy vbios to system memory. This happens with the Nvidia closed source driver but Nouveau runs fine. Is my board bad? I’m attaching the output of nvidia-bug-report.

Thanks again,
nvidia-bug-report.log.gz (82 KB)

I don’t think your board is broken, this looks like a combo of driver/kernel preemption which doesn’t work:

RmInitAdapter failed! (0x30:0xffff:664)

Mind the 664, from my observations so far this points to kernel preemption and

Linux version 4.15.9-1-default (geeko@buildhost) (gcc version 7.3.1 20180307 [gcc-7-branch revision 258314] (SUSE Linux)) #1 SMP PREEMPT

PREEMPT: fully preemptible kernel. See if SuSE also provides a kernel with voluntary preemption or no preemption and try that.

Cool … I’ll try that. Is this an issue on the punch list to be fixed?
Thanks again. I’ll report back after I build up a kernel.