On module I2C timeout


We developed a carrier board for B01 Jetson nano, and found that on module I2C is not working.
We tried to cat /sys/bus/i2c/6-0040/iio-devices/in_voltage0_input, system is reporting “Connection timed out”.

Any external requirements needed on carrier board to enable the on the module I2C?


Is it typo? Your path is not correct.
Below is my result.

nvidia@dhcp-10-19-107-83:~$ cat /sys/bus/i2c/devices/6-0040/iio_device/in_voltage0_input

Hi Shane,

Thanks for the feedback, I double confirmed, it’s the same command, I also tried on the developer kit, it works fine.

The cause could be that we customized the carrier board, but as I check the design reference, this channel of I2C is on Jetson module, so we don’t have access to debug the signal.

Is there any rules for the carrier board to make the on-module I2C work?

Did you do any change on CAM_I2C pin 213 & 215?

Hi Trumany,

Previously we removed R488 and R655 for CAM1 I2C pull up, because we only reserved one CSI camera interface, we also considered this could be a issue, so we added back these two resistances in current version,

On other thing, I noticed that CAM I2C is also routed to the RTS5411 USB HUB, does this also matters?
I know that on developer kit, the RTS5411 is configured with efuse by Realtek, for us it could be different.


Sure it will be affected if your usb hub has different setting. You can measure the I2C signal to verify that.

Thanks, we tried to disconnect the CAM_I2C from RTS5411, the INA3221 works from, but still, I’m wondering why the on module I2C is impacted.

Also, for the RTS5411 USB hub, we should contact Realtek for configuration of chips? Or we need to change to other USB hubs?


Would you please check the i2c signal on RTS5411 side?
The RTS5411 I2C bus may be configured as master mode conflicted with Xavier i2c master or pull down signal for GPIO config.

Let me raise some questions within the present topic as I find them relevant to the problem, described by yawei.yang. We are developing a custom carrier board for Jetson Nano and missing the following information:

  1. What is the purpose of CAM_I2C connection to RTS5411S USB hub in the Jetson Nano reference design schematics?

  2. Do I conclude correctly from edli1983’s reply that I2C on RTS5411S must be configured as a slave for the proper CAM_I2C bus operation?

  3. Is I2C on RTS5411S is somehow controlled by Jetson Nano or it configures with efuse by Realtek, as yawei.yang mentioned?

We would like to avoid a mistake in the design for ourselves and all the developers, so the answer would be much appreciated.

Hi Nicomalkov,

Please help to open a new topic for your issue. Thanks