I2C BUS 1 Broken on Jetson Nano

Jetson Nano Developer Board
Jetpack 4.4

Problem with I2C BUS

The I2C 1 bus is incredibly slow.

i2cdetect -y -r 0 is snappy and returns address results in a few milliseconds.
However i2cdetect -y -r 1 takes about three seconds per address!

If I try to read or write to a connected board over i2c I inevitably get ERRNO 110 timeout error.

I have seen multiple other topic entries with similar problem concerning the i2c bus on nano dev boards. All ended up having to go through RMA process.

I am also getting various i2c probe errors on bootup which is concerning, I think the bus is completely corrupted.


  1. I tried to reflash with a fresh JP4.4 sd card, but the problem persists.
  2. I checked voltage on sda/scl gpio pins which look correct


  1. Does anyone know why there are so many issues with I2C on nano boards?
  2. Is there a way to recover the i2c bus once it is corrupted? i2cdetect man does not seem to have any cmds regarding restarting the bus itself.
  3. Is there a way I can switch over to using I2C BUS 0 instead of 1 by adjusting the device tree?

Any tips/feedback or suggestions appreciated. cheers

Did you connect any device on this bus? I run the i2cdetect command on my side without problem.

Yes connected PCA9685 PMW Servo Module and cannot probe for address. I tried the same board on a Raspberry Pi and I am able to connect and communicate over I2C just fine.

It appears to specifically be a problem the I2C Bus 1, as mentioned before even the I2C 0 bus is working well on my nano.

This is the log I get at boot up.

Getting strange i2c probe errors on my imx219 board even though it is only connected over CSI.

Don’t understand what do you mean only connected over CSI?

Hey, you can pretty much disregard the IMX Error, just showing the strange i2c probe error I am getting at boot up time.

The core problem is that my I2C Bus 1 itself does not work.

Do you mean only connect the Pi v2 sensor on the Nano get the i2c error?

But imx219 is not connect to the bus 1 thought. “imx219 8-0010” it’s bus 8

@ShaneCCC thank you for your replies.

Yes, thats why i said strange error. I can check Bus 8 and I am retrieving addresses and everything looks ok.

However, I run into problems when I try to connect anything to Bus 1. I cannot even retrieve addresses on Bus 1.

I have tried connecting PCA9685 16 Channel 12-Bit PWM Servo Motor Drive which connects on Bus1 so it does not work. I connected to a Rasp Pi and it works correctly.

I also have tried to connect he Arducam PTZ board which uses Bus 1. Works on Pi but not on the Nano.

@ShaneCCC Do you have any recommendations on looking into why my Bus 1 is corrupted. Are there certain configuration files I should look at?

Have you try to connect to pin 27/28 bus 0?

Is this still an issue to support? Any result can be shared?

I ordered a new Jetson Nano board which fixed the issue-- can confirm it was a hardware issue with my I2C bus.

Thanks for the tip about using pin 27/28 for Bus 0. Will give it a try when I get a chance.