Problem with i2c 1 on Jetson Nano

I have a problem with the nano I bought in your store back in december. It seems that I can’t connect with any I2C device. Indeed if I run the command “sudo i2cdetect -y -r 1”, this takes a lot more time than it should (around 10s by address) and does not detect any device (note that when I run “sudo i2cdetect -y -r 0” it works properly). What can I do to fix this ? It seems to be a hardware problem since I tried to boot the nano with a new SD card and it didn’t changed anything.
Thanks for your help

I check the command with bus 0 and 1 both of them are no different.
Did you connect any device to the bus 1 while issue the detect command?

I tried before and after connecting something to the i2c1 bus and the result was the same. I also tested with the bus 0, with this one it didn’t detect my device either (but the output of the command wasn’t slow like with bus 1). Did you do something special to activate I2C or something like that ?

No, I didn’t do anything just boot the Linux and didn’t connect any i2c device to the bus eight.

Thanks for your answer, do you have any suggestion on what I should do ? Can i send back my Nano to get a working one ?
Also why did you mention bus eight ? Is there something special with this one ?

See here for info about the RMA process: