only one core of a quad-core CPU detected

I installed RHEL 5.3 64-bit on a new build with the Foxconn Destroyer motherboard.

However, file proc/cpuinfo shows only one core, while I have a quad-core 3-GHz AMD Phenom II:

[root@localhost proc]# more cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 16
model : 4
model name : AMD Phenom™ II X4 940 Processor
stepping : 2
cpu MHz : 800.000
cache size : 512 KB
physical id : 0
siblings : 1
core id : 0
cpu cores : 1
apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp
lm 3dnowext 3dnow constant_tsc pni cx16 popcnt lahf_lm cmp_legacy svm extapic c
r8_legacy altmovcr8 abm sse4a misalignsse 3dnowprefetch osvw
bogomips : 6029.80
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate [8]

I used the parameter pci=nomsi for the kernel, when installing RHEL 5.3, as advised.

Do I have to add another parameter for the kernel, or modify the above one?

Thank you!

Also, forgot to point out that the frequency of the only core is 800 MHz, while the CPU is a 3-GHz one.

Make sure all your settings are set to the stock correct setting in the bios. Also make sure there is significant voltage on your Fsb and Cpu Vcore. Also i know that in the 790i bios there is an option to select weather core 0 core 1 core 2 and core 3 or either on or off. Just speaking from expeience i know that i overclocked my q6600 and if there wasn’t enough voltage sometimes the bios would boot using only one Core from my cpu… Thats just my little tid bit… hope it helps.

How to check for significant voltage on the Fsb and Cpu Vcore?

Mainly there on auto, or a setting made by the motherboard. I would just either pull out a manual, go to the manufacture site, or google your cpu name and the put “stock voltage”.

Hmmm, you’re past the point of things I’ve tried. My Phenom 9950 is showing up as four cores, and I didn’t have to set anything in particular in the BIOS.

tmurray, could you please order a 3-GHz AMD Phenom II 940, and try it on the Foxconn Destroyer, and help resolve any issues?

NVIDIA should make sure that your producs are compatible with the best components at the moment, and the Destroyer is the only

motherboard that can accept 4 Tesla C1060 cards, and the 940 is the fastest CPU with the biggest L3 cache that can fit there.

Making sure that they are compatible will increase the demand for Tesla C1060s.

Thank you so much!

Are you using the right Linux kernel?

What is the output of “uname -a”?

I cannot get to log now.

But the GRUB menu is listing only one kernel, which ends on -128.el5 and that is RHEL 5.3.

However, after plugging one Tesla C1060 in PCI-E slot 3, I now have the following problem:

the system just hangs after the GRUB screen.

It prints the following messages:

at the bottom of the screen:

Kernel alive

kernel direct mapping tables up to 320000000 @ 8000-16000

at the top of the page:

root (hd0, 0)

Filesysem type is ext2fs, partition type 0xfd

kernel /vmlinuz-2.6.18-128.1.1.el5 ro root=/dev/md2 pci=nomsi rhgb quiet

[Linux-bzImage, setup=0x1e00, size=0x1cb45c]

initrd /initrd-2.6.18-128.1.1.el5.img

[Linux-initrd @ 0x37d67000 0x2881fc bytes]

Memory for crash kernel (0x0 to 0x0) not within permissible range

…and then the system hangs and does not advance further\

Normally, it would then print a list of services that are being activated, followed by [OK].

How could I fix this?

The above was happening with a Tesla C1060 card plugged into the 3rd PCI-E slot out of the 4 available, so that the card will be far from the CPU to get less affected by its heat and to still be in a 16x slot.

I also downgraded the CPU to an AMD 9850.

After removing the card, the system boots, but pauses for about 5 second after

Memory for crash kernel (0x0 to 0x0) not within permissible range.

‘uname -a’ gives:

uname -a

Linux localhost.localdomain 2.6.18-128.1.1.el5 #1 SMP Mon Jan 26 13:58:24 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

The AMD 9850 has all its four cores recognized now, but they are clocked at 1.3 GHz, as opposed to 2.5 GHz that they should be clocked at:

more proc/cpuinfo

processor : 0

vendor_id : AuthenticAMD

cpu family : 16

model : 2

model name : AMD Phenom™ 9850 Quad-Core Processor

stepping : 3

cpu MHz : 1300.000

cache size : 512 KB

physical id : 0

siblings : 4

core id : 0

cpu cores : 4

apicid : 0

fpu : yes

fpu_exception : yes

cpuid level : 5

wp : yes

flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov

pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp

lm 3dnowext 3dnow constant_tsc pni cx16 popcnt lahf_lm cmp_legacy svm extapic c

r8_legacy altmovcr8 abm sse4a misalignsse 3dnowprefetch osvw

bogomips : 5005.25

TLB size : 1024 4K pages

clflush size : 64

cache_alignment : 64

address sizes : 48 bits physical, 48 bits virtual

power management: ts ttp tm stc 100mhzsteps hwpstate [8]

processor : 1

vendor_id : AuthenticAMD

cpu family : 16

model : 2

model name : AMD Phenom™ 9850 Quad-Core Processor

stepping : 3

cpu MHz : 1300.000

cache size : 512 KB

physical id : 0

siblings : 4

core id : 2

cpu cores : 4

apicid : 1

fpu : yes

fpu_exception : yes

cpuid level : 5

wp : yes

flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov

pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp

lm 3dnowext 3dnow constant_tsc pni cx16 popcnt lahf_lm cmp_legacy svm extapic c

r8_legacy altmovcr8 abm sse4a misalignsse 3dnowprefetch osvw

bogomips : 4999.94

TLB size : 1024 4K pages

clflush size : 64

cache_alignment : 64

address sizes : 48 bits physical, 48 bits virtual

power management: ts ttp tm stc 100mhzsteps hwpstate [8]

processor : 2

vendor_id : AuthenticAMD

cpu family : 16

model : 2

model name : AMD Phenom™ 9850 Quad-Core Processor

stepping : 3

cpu MHz : 1300.000

cache size : 512 KB

physical id : 0

siblings : 4

core id : 3

cpu cores : 4

apicid : 2

fpu : yes

fpu_exception : yes

cpuid level : 5

wp : yes

flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov

pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp

lm 3dnowext 3dnow constant_tsc pni cx16 popcnt lahf_lm cmp_legacy svm extapic c

r8_legacy altmovcr8 abm sse4a misalignsse 3dnowprefetch osvw

bogomips : 5000.13

TLB size : 1024 4K pages

clflush size : 64

cache_alignment : 64

address sizes : 48 bits physical, 48 bits virtual

power management: ts ttp tm stc 100mhzsteps hwpstate [8]

processor : 3

vendor_id : AuthenticAMD

cpu family : 16

model : 2

model name : AMD Phenom™ 9850 Quad-Core Processor

stepping : 3

cpu MHz : 1300.000

cache size : 512 KB

physical id : 0

siblings : 4

core id : 1

cpu cores : 4

apicid : 3

fpu : yes

fpu_exception : yes

cpuid level : 5

wp : yes

flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov

pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp

lm 3dnowext 3dnow constant_tsc pni cx16 popcnt lahf_lm cmp_legacy svm extapic c

r8_legacy altmovcr8 abm sse4a misalignsse 3dnowprefetch osvw

bogomips : 4999.94

TLB size : 1024 4K pages

clflush size : 64

cache_alignment : 64

address sizes : 48 bits physical, 48 bits virtual

power management: ts ttp tm stc 100mhzsteps hwpstate [8]

Questions:

  1. How could I get the one Tesla C1060 card to work with this configuration?

  2. How can I get the CPU to be clocked at its normal frequency of 2.5 GHz ?

Thank you!

2 is normal down clocking to save energy. Once you start to use the core, it will ramp up the clock.

1 seems like a BIOS problem.

How could I check what the frequency will be when I start using the CPU?

What could I change in the BIOS to get to use the one Tesla C1060?

You guys at NVIDIA have tested 4 C1060s with the Foxconn Destroyer motherboard.

What settings did you change in the BIOS?

cat /proc/cpuinfo while a CPU process is running. If you have a multithreaded program, you should see more than one core ramping up the clock ( each core has its own clock).

Sorry, I am not involved with motherboard/card testing.

Who at NVIDIA is involved in the motherboard/card testing?

Could they please help here?

No settings in the BIOS had to be changed to make the C1060s work or anything like that.

I restored the default optimized settings of the BIOS and was able to boot and have the four

AMD Phenom II 940 cores listed, but each of them at 800 MHz.

However, sometimes when I boot, there is only one core listed, and if I reboot then there are 4.

Any ideas why that is happening?

As has already been said. This is normal. The OS will ramp the clock down to save power when it isn’t needed. Run cpuburn or something and watch the clocks go back up.

Nope. But you might try a linux distrubution with a more modern kernel. Say, the latest version of Fedora that supports CUDA. RHEL runs positively ancient versions of the kernel which might lead to issues with the latest and greatest hardware.

I have had similar issues with Kubuntu 8.04 install kpowersave and then start it and set it to performance. That should bring your clock speed up to 3000.

Ok, i had the exact same problem, but found a fix:

And yes, it sounds insane, but it works.

In the bios, set: USB Keyboard, Mouse, and Storage Supported to disabled.

Got the clue from here: http://ubuntuforums.org/archive/index.php/t-658155.html

Everything then works, also the keyboard and mouse:)

SOLVED!

This may be due to the inconsistence of ACPI settings in BIOS and the linux kernel.

Go into BIOS settings and enable ACPI or edit your grub configuration file to pass parameter acpi=off to the linux kernel works for me!