OpenCV import error on Spyder3 on Jetson TX2

Does anyone know why I keep getting error while trying to import cv2 on Spder3 on Jetsonson TX2? I have already successfully installed opencv using terminal and don’t error while importing cv2 from Terminal’s Python3.

I cannot say about spyder nor ipython, but you may try to find which version of opencv is found:

python  (or python3)
import cv2

If you find an old version, you may try to build and install a recent opencv4 version such as here for 4.1.1

1 Like

@Honey_Patouceul I have version 3.2.0. Is this incompatible? I will try to build the latest on 4.1.1 from the link provided by you and see if that works. Thanks!

You would tell if it improves or not.
If it really needs TLS, there might be some extra options required (not looked at, though), but let’s first try a more recent version.

@Honey_Patouceul I did build opencv as explained in the tutorial. The build was successful. However, I kept getting same error. But the solution that worked for me after different hit and trial was importing “opencv” first and then “cv2”. So when I use : import opencv
import cv2
It works!