Opensuse 12.3 Nvidia CUDA 5.5 install issues

Hello Folks,

I’m having some issues with installing. Here are the steps I have taken.

I have installed the nvidia driver, seems to work perfectly. I downloaded cuda_5.5.22_linux_64.run and ran it.

I got it to install the toolkit in /usr/local/cuda/
I got it to put the samples in my home dir
I didn’t install the driver using this method, it doesn’t work plus compiled cuda apps work fine.

I have added /usr/local/cuda/bin to my /etc/bash.bashrc.local file and I can see the cuda compiler etc from the command line.
I have created /etc/ld.so.conf.d/cuda.conf file and in it I have put /usr/local/cuda/lib and lib64. I then ran ldconfig

I also tried just exporting the lib/lib64 dirs, just in case.

I also rebooted after doing all this.

gcc version is 4.7.2, I didn’t get any messages about it not being supported.

When I try to make the samples I get the error:
cc1plus: fatal error: cuda_runtime.h: No such file or directory.

I didn’t get any other errors during the install process. Any ideas why it can’t find the headers? I think I got all the steps.

Phil

Hi Phil,
Can you please check env “CUDA_PATH” in Makefile of your samples?
For example:
cd ~/NVIDIA_CUDA-5.5_Samples/NVIDIA_CUDA-5.5_Samples/1_Utilities/deviceQuery grep “CUDA_PATH” Makefile
cd /usr/local/cuda/samples/1_Utilities/deviceQuery grep “CUDA_PATH” Makefile

The env “CUDA_PATH” should equal to CUDA installation path. And the header files are located in ${CUDA_PATH}/include.

The CUDA_PATH is /usr/local/cuda-5.5 which is correct, although I have a symlink from there too /usr/local/cuda I added /usr/local/cuda-5.5 to my path just in case it didn’t help.

I will try reinstalling, I just have to wait for a data analysis job to finish running…

Could you please run “make” under sample dir? It’s helpful to troubleshoot.
cd ~/NVIDIA_CUDA-5.5_Samples/NVIDIA_CUDA-5.5_Samples/1_Utilities/deviceQuery make
ls /usr/local/cuda-5.5/include cd /usr/local/cuda-5.5/samples/1_Utilities/deviceQuery
sudo make sudo make clean

This is a test post…

Right, I tried to post and it failed, very annoying… try again.

Sorry for being slow getting back to this. I was demonstrating science at the British Science Festival. :)

Ok, with the machine rebooted it still finds nvcc etc, and the /etc/ld.so.conf.d/cuda.conf has the path to /usr/local/cuda/lib64 and lib set. There is a symlink from /usr/local/cuda to /usr/local/cuda-5.5.

If I run make on deviceQuery I get the following error:

"/usr/local/cuda-5.5"/bin/nvcc -ccbin g++ -I../../common/inc  -m64    -gencode arch=compute_10,code=sm_10 -gencode arch=compute_20,code=sm_20 -gencode arch=compute_30,code=sm_30 -gencode arch=compute_35,code=\"sm_35,compute_35\" -o deviceQuery.o -c deviceQuery.cpp
deviceQuery.cpp:20:18: fatal error: cuda.h: No such file or directory
compilation terminated.
make: *** [deviceQuery.o] Error 1

Same if I run “sudo make” after make clean etc.

The CUDA_PATH in the MakeFile is correct I checked with grep as suggested.

Any other suggestions?

I opened up Nsight and created a test project from the template. It couldn’t find cuda_runtime.h, so I added the path /usr/local/cuda/includes manually to the project. This suggests that the includes cannot be found generally.

Update on the above: If I import the DeviceQuery sample into Nsight and add the path to the includes to the project it can find cuda.h and cuda_runtime.h but I get the following error now.

ld: cannot find -lcudart_static

So there is still something wrong with the paths.

Did a total delete, download again and re-install. Got it! Its now working.