Optimus GM108M fallen off the bus after a few minutes - all latest packages

I have a Dell Vostro 5480 that features a NVIDIA GM108M [GeForce 830M] along with an integrated Intel VGA card (there’s no BIOS setting regarding the graphics cards).

I set it up to use only the NVIDIA card (with the proprietary driver) with this simple xorg.conf:

Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:8:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

Everything works perfectly well until after a few minutes when X crashes completely. It seems to be totally unrelated with what I’m doing. I’ve tried working with different applications, leaving it idle, and even different DEs (XFCE, KDE, etc). All resulting in the same crash after a few minutes.

I then ssh into the machine, verify that Xserver is stuck at 100% usage in one core. In journalctl I find the following message:

kernel: NVRM: GPU at 0000:08:00.0 has fallen off the bus.
kernel: NVRM: A GPU crash dump has been created. If possible, please run
        NVRM: nvidia-bug-report.sh as root to collect this data before
        NVRM: the NVIDIA kernel module is unloaded.

I’m using Arch Linux with the following packages’ versions:

linux 4.4.1-2
xorg-server 1.18.1-3
xorg-xrandr 1.4.3-1
nvidia 361.28-1
nvidia-utils 361.28-5
nvidia-libgl 361.28-5
lib32-nvidia-libgl 361.28-4
lib32-nvidia-utils 361.28-4

I did not found how to attach the nvidia-bug-report.log.gz here, so here’s a link to it:
https://drive.google.com/open?id=0BxfBwM8xuKeSTWFyNWFsNkV5VUE

Can anyone help? If you need more information or that I try any different setup (even hunches), please let me know.

I’ve updated to latest nvidia and xorg versions and it still doesn’t work :-(

linux 4.5.1-1
xorg-server 1.18.3-1
xorg-xrandr 1.5.0-1
nvidia 364.19-1
nvidia-utils 364.19-1
nvidia-libgl 364.19-1
lib32-nvidia-utils 364.19-1
lib32-nvidia-libgl 364.19-1