X crashes with no informational error on a GM108M [GeForce 840m] (rev a2)

When starting Xorg with the proprietary nvidia driver version 390.59-1 amd64 on debian unstable, Xorg crashes with no understandable reason, no info given, i have experienced this problem a few months ago on the same laptop, i gave up and used windows. So the driver version probably isn’t important, maybe even a different distro, certainly different version of debian.
I’m attaching Xorg.log, dmesg output, and the log.gz file that nvidia-bug-report generated.

http://62.168.71.236/Xorg.0.log
http://62.168.71.236/dmesg.log
http://62.168.71.236/nvidia-bug-report.log.gz

The kernel driver fails:
NVRM: RmInitAdapter failed! (0x26:0xffff:1123)
Try a later driver, 390.67 or 396.24

I tried 390.67, actually running it right now. Now it errors out with: (EE) Failed to load module “nvidia” (module doesn’t support this OS, 0)

I’m now running the other driver you recommended, 396.24. No luck with this one either, the same error happens.

Did this at any time work with linux and the proprietary driver?
Things to try:

  • upgrade bios
  • set kernel parameter
    acpi_osi=! acpi_osi=“Windows 2009”

It never worked, i’m going to revert to the driver’s which crashed and try those kernel options.

Ok, now even the debian nvidia drivers dont support debian… like wtf

What’s the dmesg output?

Nothing, only that an out of tree module taints the kernel, and that it’s unloading the nvidia module, im may try reinstallation, and those kernel options you suggested. If i can get the driver to crash and complain about my OS, i might be able to use those kernel options to make it work. what do you think?

I have no idea how you managed to get that, I’ve never seen this error. Sounds like some harddisk corruption or broken links.

Ok, I’m back to the original non informational error, I tried the kernel parameter you suggested, and if didn’t work. I again have no clue what to do…

I updated the bios to the latest one, still the same error

Looks like debian doesn’t provide a newer driver that 390.59 and you should stay away from the installer from nvidia’s website. So you’re stuck with that version right now.
But you should update your bios, looks like the initial version the laptop came with.

No clue what was the original probably the one I updated from, I can’t imagine my friend updatng, it by him self. Also I found a thread with no comments, except the actual question. The guy said that he is getting the same error as I am getting. He also said he has 2 1080Ti and only one of them has this issue, so I’m thinking that it just might be a defective gpu. Idk

Found it: https://forums.geforce.com/default/topic/1044766/geforce-1000-series/one-1080ti-doesn-t-work-in-ubuntu-16-04-other-identical-one-does-/

When I wrote about updating your bios, your post about having updated it was not visible. This forum software does strange kind of things.
The post about the 1080 sounds like broken hardware. That’s the problem with those RmInitAdapter errors, can be about anything. Since the nvidia driver is a black box you can only take a stick and poke at it.
Since you’re also running Windows, did you ever run a benchmark test like some Unigine demo on it to rule out a hardware issue?