X Server crash on startx with nvidia driver 495.46


Since the installation of the 495.46 drivers, i can’t start a grapic session.

i am an archlinux user with a gtx 1060 6gb from PNY

nvidia-bug-report.log.gz (296.5 KB)

1 Like

Your log shows you’re running an old kernel version - have you updated fully?

If you added the nvidia* modules to your mkinitcpio.conf you’ll also have to rebuild the initramfs,

It will also be worth checking the Arch forum for similar threads.

Hello jonathon,

i have updated fully, this resulted in xorg crash, so i rollbacked my system to the 13 december (the last day before the 495.46), no more xorg crash, then i added all the other package except from the nvidia ones from the 14 december still no crash, then added the nvidia ones wich resulted in crash.

i also fully updated my system to a further date since, and same result.

i checked the arch forum first and then the package bug tracker, the package’s manager said there was no change between 44 and 46.

i am not the only one with this issue, but the only one reporting here.

hello @user191239281

I have same issue with my laptop Alienware which has “NVIDIA Corporation GK106M [GeForce GTX 765M] (rev a1)”, after fully upgraded system the xorg crach and found that nouveau modules is loaded due absence of nvidia even I have nvidia modules inside mkinitcpio.conf and kernel parameter on boot loader has nvidia-drm.modeset=1

Now I upgraded my system to latest package except nvidia 470.63.01-11 and that work, if I upgrade to 495.46-1 I will loose my xorg. Hope you look to this issue since we are very affected. Thanks

Hello, I am also seeing the same behavior. For specifics I am running:

  • A fully updated Arch Linux install (most recent kernel, etc)
  • The MATE desktop environment with lightdm as the launcher
  • Nvidia drivers

The behavior after updating to 495.46 is that when I boot into the machine, I get the graphical lightdm GUI. However, when I put in my auth creds to log in, the screen goes blank for a second, and then I get a fresh login screen. X appears to be crashing and dumping core when this happens.

I am attaching several files in the hopes they help.

  • nvidia-bug-report.log.gz generated with sudo nvidia-bug-report-sh
  • Xorg.coredump.txt generated with sudo coredumpctl info <pid> where <pid> was grabbed from coredumpctl list | tail -1
  • Xorg.coredump.bin.xz generated with sudo coredumpctl --output=/home/${USER}/Xorg.coredump.bin dump Xorg && xz Xorg.coredump.bin

As with the other folks reporting this, if I downgrade back to the 495.44 drivers, everything starts working again per normal. The same behavior has been seen for the vanilla and -zen versions of the 5.15.7, 5.15.8, and 5.15.10 kernels (so I have tested across six kernels total).

If I can provide any additional information, please let me know. Thanks!

nvidia-bug-report.log.gz (320.8 KB)
Xorg.coredump.txt (7.9 KB)
Xorg.coredump.bin.xz (2.0 MB)

1 Like

On line 10496 of your log file it specifies that you are running kernel 5.15.7:

[    0.000000] Linux version 5.15.7-arch1-1 (linux@archlinux) (gcc (GCC) 11.1.0, GNU ld (GNU Binutils) 2.36.1) #1 SMP PREEMPT Wed, 08 Dec 2021 14:33:16 +0000

Later, on line 11313, it specifies you are loading the NVIDIA driver module version 495.46:

[    5.451435] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  495.46  Wed Oct 27 16:31:33 UTC 2021

This indicates you are not fully updated, and this will be why the driver module doesn’t load. To quote the well-known Arch phrase: “partial upgrades are not supported”.

This is not the same issue. Your GPU is not supported by the 495xx series as provided by the repo’s nvidia driver - you must switch to the 470xx packages in the AUR.

@user191239281 , Thanks for your help.
That was not mentioned on arch wiki under nvidia before 2 days ago and today is updated “For the Kepler (NVE0) series (including GeForce 630-920) from around 2013-2014, install the nvidia-470xx-dkmsAUR package.”
I have installed this package and working good now with fully upgraded system.

My issue is resolved and hope other guys too.

@user191239281 5.15.7-arch1-1 is the kernel matching with 495.46-1 on archlinux

i did several test before and after the log file, with a mirror list set on differents date from arch linux archive, and typed pacman -Syyuu


Ah yes, so it is (looks like there was a ~one-day window).

However, this is still out-of-date. Update fully, then generate a new log file if the issue persists.

You mean it was updated on the 31st October? :wink:

Not really because I spent 2 days on wiki and read it many times but didn’t notice this update, Maybe browser cache issue. when you mentioned the package and go directly and check wiki again and found it. Thanks for your patience

@user191239281 This issue is still persisting after a full upgrade, here is the new log file:

nvidia-bug-report.log.gz (270.2 KB)

1 Like

Haven’t run into this myself, but as maintainer of the package in Gentoo I did have a few users report issues saying that .44 worked but .46 didn’t with a similar-looking backtrace ending with libpthread (may possibly show libc instead if using glibc-2.34 given libpthread was merged in libc.so in 2.34).

Edit: the dbus spamming issues and now this been quite a headache with 495 branch (not to mention managing GBM, but that’s new and not regressions), thankfully production 470.xx is still the branch we’re handing to most users in stable which seems to be working out fine – I recommend 470.94+ to anyone having issues until the next production branch.

1 Like

Hmm. There’s nothing obvious to me in there. :pensive:

There’s a collection of similar issues here: FS#73031 : [nvidia] several xorg aborts w/ nvidia-495.46-1

As far as I’ve seen to date, there doesn’t seem to be any pattern to this, although in two other instances a BIOS update helped.

The other workaround (as hinted by ionen above) would be to switch to the 470xx drivers from the AUR.

Also thinking about it, can you verify the updated nvidia package is 495.46-4 to match with kernel 5.15.10?

Something else to try would be using nvidia-dkms instead of the pre-compiled driver module.

@user191239281 i will probably wait for a new driver from this branch or another to release, hopping this one will work.

Thank you for your help, and have a nice holyday.

Others are reporting the same or similar issue: 495.46 Xorg SIGSEGV in Fedora 35, only on MSI MPG Trident3, and only for MATE desktop

@ha173 thank you, i am also using mate desktop.

Can you check whether this helps?

(I can send a patched Xorg package, or you can find it in my unofficial repo)

Thanks for reporting this. Assuming this is the same issue, I filed internal bug number 3484117 to track down what’s going on here.

i can confirm this is the same issue, patched Xorg and Marco compositor activated and no more crash.

1 Like