Centos 7, GeForce GT740, unable to start X server

I have a Linux machine running Centos 7. It has a GeForce GT 740 card.

[johnjaco@johnjaco-lnx: ~] uname -a
Linux johnjaco-lnx 3.10.0-957.1.3.el7.x86_64 #1 SMP Thu Nov 29 14:49:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[johnjaco@johnjaco-lnx: ~] lspci | grep NVIDIA
06:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 740] (rev a1)
06:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)
[johnjaco@johnjaco-lnx: ~] lsmod | grep nvidia
nvidia_drm             43915  0 
nvidia_modeset       1036573  1 nvidia_drm
nvidia              16628708  1 nvidia_modeset
ipmi_msghandler        56032  3 ipmi_devintf,nvidia,ipmi_si
drm_kms_helper        179394  1 nvidia_drm
drm                   429744  4 ttm,drm_kms_helper,nvidia_drm

For the past two years, this is the process that I have followed:

  1. Run “yum update” manually every week or so.
  2. If the kernel updates, download the latest .run nVidia driver installer and reinstall the driver.

This has worked fine for the past two years or so.

However, ever since my last kernel update at the end of 2018, this has stopped working. I have tried reinstalling various different driver versions from the nVidia site, and none of them work any more. Xorg.0.log (after running startx – -logverbose 6) shows:

[  3695.072] 
X.Org X Server 1.20.1
X Protocol Version 11, Revision 0
[  3695.072] Build Operating System:  3.10.0-693.17.1.el7.x86_64 
[  3695.072] Current Operating System: Linux johnjaco-lnx 3.10.0-957.1.3.el7.x86_64 #1 SMP Thu Nov 29 14:49:43 UTC 2018 x86_64
[  3695.073] Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-957.1.3.el7.x86_64 root=UUID=d7caf744-370e-460b-8b80-d43098a3026a ro crashkernel=auto rhgb quiet LANG=en_US.UTF-8 nomodeset
[  3695.073] Build Date: 15 November 2018  04:59:43PM
[  3695.073] Build ID: xorg-x11-server 1.20.1-5.1.el7 
[  3695.073] Current version of pixman: 0.34.0
[  3695.073] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  3695.073] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3695.074] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan  3 12:49:50 2019
[  3695.074] (==) Using config file: "/etc/X11/xorg.conf"
[  3695.074] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  3695.074] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3695.075] (==) ServerLayout "Layout0"
[  3695.075] (**) |-->Screen "Screen0" (0)
[  3695.075] (**) |   |-->Monitor "Monitor0"
[  3695.075] (**) |   |-->Device "Device0"
[  3695.075] (**) |-->Input Device "Keyboard0"
[  3695.075] (**) |-->Input Device "Mouse0"
[  3695.075] (==) Automatically adding devices
[  3695.075] (==) Automatically enabling devices
[  3695.075] (==) Automatically adding GPU devices
[  3695.075] (==) Automatically binding GPU devices
[  3695.075] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  3695.075] (**) FontPath set to:
	catalogue:/etc/X11/fontpath.d,
	built-ins,
	catalogue:/etc/X11/fontpath.d,
	built-ins
[  3695.075] (**) ModulePath set to "/usr/lib64/xorg/modules"
[  3695.075] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  3695.075] (WW) Disabling Keyboard0
[  3695.075] (WW) Disabling Mouse0
[  3695.075] (II) Loader magic: 0x5558b4d1f020
[  3695.075] (II) Module ABI versions:
[  3695.075] 	X.Org ANSI C Emulation: 0.4
[  3695.075] 	X.Org Video Driver: 24.0
[  3695.075] 	X.Org XInput driver : 24.1
[  3695.075] 	X.Org Server Extension : 10.0
[  3695.076] (II) xfree86: Adding drm device (/dev/dri/card0)
[  3695.076] (II) Platform probe for /sys/devices/pci0000:00/0000:00:03.0/0000:06:00.0/drm/card0
[  3695.077] (II) Platform PCI device at pci:0000:00:03.0
[  3695.109] (--) PCI: (6@0:0:0) 10de:0fc8:3842:2744 rev 161, Mem @ 0xc6000000/16777216, 0xb0000000/268435456, 0xc0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[  3695.109] (--) PCI:*(8@0:0:0) 102b:0522:1137:0101 rev 2, Mem @ 0xc4000000/16777216, 0xc5810000/16384, 0xc5000000/8388608, BIOS @ 0x????????/65536
[  3695.109] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  3695.109] (II) LoadModule: "glx"
[  3695.109] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  3695.111] (II) Module glx: vendor="X.Org Foundation"
[  3695.111] 	compiled for 1.19.3, module version = 1.0.0
[  3695.111] 	ABI class: X.Org Server Extension, version 10.0
[  3695.111] (II) LoadModule: "nvidia"
[  3695.111] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  3695.111] (II) Module nvidia: vendor="NVIDIA Corporation"
[  3695.111] 	compiled for 4.0.2, module version = 1.0.0
[  3695.112] 	Module class: X.Org Video Driver
[  3695.112] (II) NVIDIA dlloader X Driver  410.93  Thu Dec 20 17:07:57 CST 2018
[  3695.112] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  3695.112] (II) NVIDIA X compatibility module for ABI 24.0 built from xorg-server-1.19.99.902
[  3695.112] (II) X log verbosity: 6
[  3695.112] (--) using VT number 2

[  3695.118] (EE) No devices detected.
[  3695.118] (EE) 
Fatal server error:
[  3695.118] (EE) no screens found(EE) 
[  3695.118] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  3695.118] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  3695.118] (EE) 
[  3695.124] (EE) Server terminated with error (1). Closing log file.

I’m attaching xorg.conf, nvidia-installer.log, Xorg.0.log, and nvidia-bug-report.log.gz.

I’d appreciate any ideas. Thanks!

nvidia-installer.log (31.3 KB)
Xorg.0.log (4.19 KB)
nvidia-bug-report.log.gz (1020 KB)
xorg.conf.txt (1.43 KB)

This looks like there’s no monitor connected to the nvidia gpu.
Please add

BusID          "PCI:6:0:0"
Option         "AllowEmptyInitialConfiguration"

to the device section of your xorg.conf and attach a new xorg log afterwards.

Hi generix,

Thanks for your response. I tried that, but unfortunately it didn’t work. startx ended up segfaulting.

[johnjaco@johnjaco-lnx: ~] sudo startx -- -logverbose 6
xauth:  file /root/.serverauth.10889 does not exist


X.Org X Server 1.20.1
X Protocol Version 11, Revision 0
Build Operating System:  3.10.0-693.17.1.el7.x86_64 
Current Operating System: Linux johnjaco-lnx 3.10.0-957.1.3.el7.x86_64 #1 SMP Thu Nov 29 14:49:43 UTC 2018 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-957.1.3.el7.x86_64 root=UUID=d7caf744-370e-460b-8b80-d43098a3026a ro crashkernel=auto rhgb quiet LANG=en_US.UTF-8 nomodeset
Build Date: 15 November 2018  04:59:43PM
Build ID: xorg-x11-server 1.20.1-5.1.el7 
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan  4 10:59:56 2019
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) 
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x55) [0x5556bc492185]
(EE) 1: /usr/bin/X (0x5556bc2e1000+0x1b4e09) [0x5556bc495e09]
(EE) 2: /lib64/libpthread.so.0 (0x7f7c53fde000+0xf5d0) [0x7f7c53fed5d0]
(EE) 3: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f7c512e2000+0x293a1) [0x7f7c5130b3a1]
(EE) 4: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f7c512e2000+0x287d2) [0x7f7c5130a7d2]
(EE) 5: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f7c512e2000+0x27bba) [0x7f7c51309bba]
(EE) 6: /usr/bin/X (InitExtensions+0x5d) [0x5556bc3a972d]
(EE) 7: /usr/bin/X (0x5556bc2e1000+0x601d6) [0x5556bc3411d6]
(EE) 8: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f7c53c333d5]
(EE) 9: /usr/bin/X (0x5556bc2e1000+0x4a4ce) [0x5556bc32b4ce]
(EE) 
(EE) Segmentation fault at address 0x7f7c4f567948
(EE) 
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

I’ve attached xorg.conf and Xorg.0.log after making this change.

xorg.conf.txt (1.47 KB)
Xorg.0.log (500 KB)

You’re running xorg-server 1.20 but the glx module is still at 1.19, that has been happening more often lately, you have to uninstall the xorg-server package (probably using --nodeps option) and then reinstall it.

Here’s how you can automate it all. First run nvidia-uninstall and finish it.

Then run this script under root or sudo:

yum reinstall `rpm -qa | egrep -i "xorg|mesa"`

this should fix your problem if generix is correct.

Unfortunately, according to this user:
https://devtalk.nvidia.com/default/topic/1044851/linux/fyi-nvidia-410-78-driver-fails-with-segmentation-fault-on-fedora-fc29-workstation-with-nvs-510-card/post/5301675/#5301675
a simple reinstall does not fix it, you’ll have to manually uninstall, the install anew.

Hi birdie and generix,

Thank you for your responses. This worked!

  1. nvidia-uninstall
  2. yum reinstall
  3. Reinstall the nvidia driver 410.93 from the .run file.

After this, for some reason my keyboard and mouse were not working. I was able to fix this by installing xorg-x11-drv-evdev.