Debian on Acer Predator Helios 300

Hello

I tried to install the proprietary NVIDIA driver on Debian Linux Jessie.

The installer tells me that there is no nvidia card but there is:

marc@debian:~/Downloads$ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 3e9b
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)

and if reboot i get the following xorg xserver error:
(the nouveau driver is correctly blacklisted)

[ 93.113] Module class: X.Org Server Extension
[ 93.113] (II) NVIDIA GLX Module 390.67 Fri Jun 1 03:10:40 PDT 2018
[ 93.113] (II) LoadModule: “nvidia”
[ 93.113] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 93.113] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 93.113] compiled for 4.0.2, module version = 1.0.0
[ 93.113] Module class: X.Org Video Driver
[ 93.113] (II) NVIDIA dlloader X Driver 390.67 Fri Jun 1 02:45:19 PDT 2018
[ 93.113] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 93.113] (II) systemd-logind: releasing fd for 226:0
[ 93.114] (EE) No devices detected.
[ 93.114] (EE)
Fatal server error:
[ 93.114] (EE) no screens found(EE)
[ 93.114] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 93.114] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 93.114] (EE)
[ 93.120] (EE) Server terminated with error (1). Closing log file.

with kind regards
Marc Landolt

https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

My Bugreport file: https://0x8.ch/nvidia/

i tried the Xorg Config from your link but this did not work… the computer starts then it flickers in the console after 5 minutes the flickering stops and i can switch to a working console with Alt-Fx

maybe i should say that it’s a hybrid graphic card Laptop where as far as i know the Laptop Screen is attached to the Intel Coffeelake Graphics and the external HDMI Screen is attached to the NVIDIA Card

With kind regards
Marc Landolt

Unfortunately, the log is nearly empty but the kernel version. Since you say coffee lake, you need at least kernel 4.15 and you’re running 4.9.

I upgraded to Debian Buster that has 4.16…

The phenomena is still the same. I uploaded again the bug-report file…

https://0x8.ch/nvidia/20180710/

The log is still empty but you’re running kernel 4.16 now. The xorg log tell that you have some kind of strange config files maybe in /etc/X11/xorg.conf.d so you’re running two screens which doesn’t work.

have you a hint how to run two cards with one screen, because the Xorg -configure generated this and i also tried to create a correct config file with nvidia-xconfig --enable-all-gpus

Don’t know if there has been a problem with your webserver but now I can read the full log instead of just the kernel version.
One problem is that debian obviously still doen’t ship the current intel firmware:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=898267
So you will have to download and copy that manually like the bug report intructs.
The the xorg.conf you’re using doesn’t work.
Use the xorg.conf from here:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910
and create two files optimus.desktop in /etc/xdg/autostart/ and /usr/share/gdm/greeter/autostart/ containing

[Desktop Entry]
Type=Application
Name=Optimus
Exec=sh -c "xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto"
NoDisplay=true
X-GNOME-Autostart-Phase=DisplayServer
X-GDM-BypassXsession=true