X not starting after driver update

Hi there,

Just experienced an issues with update to any NVIDIA-Linux-x86_64-46XXXX driver version. Have been running NVIDIA-Linux-x86_64-455.45.01.run for a while and everything worked fine. The update procedure to NVIDIA-Linux-x86_64-46XXXX (tried 4 different version) works without any error. Manually starting X (via sddm) after the installation is finished also works fine and the system is running as expected. However, after reboot X won’t start and I get an error message “Failed to initialize the NVIDIA kernel module. … No devices detected” in the Xorg.0.log. Reinstalling the same driver makes it work for the same session but after a reboot X won’t start. Reverting back to 455.45.01 solved the problem and everything works fine again.

System:
Gefore 1070 (desktop, not mobile)
Debian Testing
SDDM Display Manger
Kernel 5.10.1 from kernel.org (vanilla)

Thanks!

As currently there’s a shortage in crystal balls, a nvidia-bug-report would be required to help. Best run (nvidia-bug-report.sh - as root) after the problem occurs.
However it’s generally recommended to use the distros packaged drivers not the .run file installer.
https://wiki.debian.org/NvidiaGraphicsDrivers#Installation
https://packages.debian.org/bullseye/nvidia-driver

Thanks for the fast response. NVIDIA customer care told me to post the issue here … they did not mention the crystal ball issue, otherwise I would not have posted it. Just wanted to help, I can live with the working version for now. Thanks for the links.

Oh, that was just me trying to be amusing :-/
All I wanted to say is, that more information is needed to help you. The nvidia-bug-report.sh script, which is installed alongside with the driver, collects a lot of information useful for debugging issues.