Orin Nano Outperforming Orin NX in glmark2?


I have a stock image of the orin Nano/NX and two devkit : 1x Orin Nano 8GB, 1x Orin NX 8GB.

I am running benchmarks on both and I get better CPU results on 7z benchmark with the NX, as expected.
But while trying glmark2-es2 benchmark, I’m getting significantly worst results on the NX.

I get 2575 with the Nano, and 2000 with the NX.
I also get the Overcurrent warning on 2 of the tests in the benchmark. I tried using the power configuration tool with MAXN option, but I get the same results.

I also tried to create my own image using the SDK with the config jetson-orin-nano-devkit, and still same results.

I may be doing something wrong. Can someone enlighten me on what could happen?

For information, do you use latest Jetpack 5.1.2?

I took the sd card image from this link :
JetPack SDK | NVIDIA Developer

And to build an image I took packages from this link :
Jetson Linux 35.4.1 | NVIDIA Developer

Anyone can tell me what I can do to make it work? It’s stock image so I thought it would just work.

Further than setting MAXN power mode, did you later maxed the clocks with:

sudo jetson_clocks

Sorry I only have an AGX Orin running a standard L4T R35.3.1 from NVME for trying.
I built and installed with:

cd ~/Desktop
git clone --recursive https://github.com/glmark2/glmark2.git
cd glmark2
# Using meson 1.2.1
meson setup build -Dflavors=x11-gl,x11-glesv2 --prefix=/home/nvidia/Desktop/glmark2-install
ninja -C build
ninja -C build install
cd ../glmark2-install/bin

For reference, glmark2 gave score 3644, all tests passed, while glmark2-es2 returned score 3329 but with tests conditionals, function and loop failing to run (no idea what is the root cause).

Not sure, but I’d advise to have similar disks for rootfs (performance may vary a lot even for reading if using different SD cards) and use same display monitor for benchmarking.
Someone more skilled may better help.

We have 20W mode for Orin NX 8GB:
Jetson Orin Nano Series, Jetson Orin NX Series and Jetson AGX Orin Series — Jetson Linux Developer Guide documentation

Please set to this mode and give it a try. In MAXN mode, all engines can run to maximum clock and if either engine drains significant current, it may trigger over current in high system loading condition.

Hi, doing jetson_clocks yielded better results than the nano. I also had to fiddle with the power settings like DaneLLL suggested. The 20w profile had better results than before, but less than “unlocking” everything.

The NX went from 2000 to 3170 on glmark2-es2.

Thank you for taking time to help.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.