Orin NX with L4T35.3.1 RTC is not saving

Hi Team,
a) I have connected good battery.
b) confirmed rtc is mapped with rtc0 ( check from /dev/ )
c)CONFIG_RTC_HCTOSYS_DEVICE=“rtc0” in tegra_defconfig

with above modification (c) build and flashed .
once board is up disabled auto date update from date setting GUI.
changed the date up to date. waited 2 minutes and
power cycled the board.
once Orin NX module up observed board date was September 08 2022

Any modification required ?


is your device connected to the Internet?
What do timedatectl and hwclock -r give you before and after reboot?

Hi @DaveYYY , Internet connected but auto date update is disabled.
before power cycle executed mentioned command and response as below.
nvidia@nvidia-desktop:~$ timedatectl
Local time: Thu 2023-06-15 16:23:57 IST
Universal time: Thu 2023-06-15 10:53:57 UTC
RTC time: Thu 2023-06-15 10:53:57
Time zone: Asia/Kolkata (IST, +0530)
System clock synchronized: yes
NTP service: inactive
RTC in local TZ: no
nvidia@nvidia-desktop:~$ hwclock -r
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --verbose option to see the details of our search for an access method.
nvidia@nvidia-desktop:~$ sudo hwclock -r
[sudo] password for nvidia:
2023-06-15 16:24:30.971405+05:30

@DaveYYY any help please… shared logs


sorry for the late reply.

We’ve seen similar cases before, and looks like the issue of system time falling back to a default value upon reboot is caused by the design of Ubuntu itself.
You may rely on sudo hwclock -r to get the timestamp if you manually set it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.