passthrough the intel gpu through nvidia gpu to the screen

hi

i have bought a alienware area-51m and have been trying to get my iGPU working on my laptop screen
but i always gets a totally black screen.i have been trying to use prime and bumblebee but can not manage to make it work.this type of laptop have a desktop gpu build in it and using its screen output to the laptop screen and i believe this is not the way it is done with other laptops.i have no problem
using the nvidia gpu but it is to hungry when i am on the fly.my hopes is to use the iGPU to handle the Desktop Environment and having the nvidia GPU for games.

regards hedmo

nvidia-bug-report.log.gz (139 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

This is a gz with a working X. Do you need a gz when i Am configure x for prime to?

Regards hedmo

Since you’re on gentoo, you’ll have to set this up manually. For using prime output, see this:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910
Maybe you just missed to run the two xrandr commands, which DM/DE are you using?

Since that model is using (power consuming) desktop hardware, I’d rather recommend looking into render offload (needs a patched Xserver and unmasked USE=libglvnd)
http://download.nvidia.com/XFree86/Linux-x86_64/435.17/README/primerenderoffload.html
http://download.nvidia.com/XFree86/Linux-x86_64/435.17/README/dynamicpowermanagement.html
https://bugs.gentoo.org/692170
https://bugs.gentoo.org/692206
The downside of this is that external monitors connected to the nvidia gpu won’t work. According to the logs, there also seem to be connectors to the igpu, are those accessible, e.g. over USB-C?

Yes i am on gentoo and have installed libgvnd,patched Xorg hade a look in your documentation.As soon as i put:

mya51 /hedmo # cat /etc/X11/xorg.conf.d/01-nvidia-offloading.conf
Section "ServerFlags"
  Option "IgnoreABI" "1"
EndSection

Section "ServerLayout"
  Identifier "layout"
  Option "AllowNVIDIAGPUScreens"
  Screen 0 "iGPU"
EndSection

Section "Device"
  Identifier "iGPU"
  Driver "modesetting"
  BusID "PCI:0:2:0"
EndSection

Section "Screen"
  Identifier "IGPU"
  Device "iGPU"
EndSection

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
  BusID "PCI:1:0:0"
EndSection
mya51 /home/hedmo #

and startx my screen shuts off but the server is running.

IgnoreABI isn’t necessary.
Please create a new nvidia-bug-report.log with that config in place.

here you go
nvidia-bug-report.log.gz (1.14 MB)

That’s the old one from yesterday.

sorry…
nvidia-bug-report.log.gz (1.14 MB)

You have both xorg.conf in place so the options add up and nothing works. It’s either or. Delete /etc/X11/xorg.conf and replace it with the offloading one. You shouldn’t put config files containing specific Device and ServerLayout sections in xorg.conf.d.

okay.here you go.
nvidia-bug-report.log.gz (1.15 MB)

I don’t know why you didn’t just copy over you already correct offload config.
Please add the busid to the nvidia section.
Remove the DRI setting from igpu device setion
keyboard and mouse sections are not necessary on modern xorg.

this is the file :

hedmo@mya51 ~ $ cat /etc/X11/xorg.conf
Section "ServerLayout"
  Identifier "layout"
  Option "AllowNVIDIAGPUScreens"
  Screen 0 "iGPU"
EndSection

Section "Device"
  Identifier "iGPU"
  Driver "modesetting"
  BusID "PCI:0:2:0"
EndSection

Section "Screen"
  Identifier "IGPU"
  Device "iGPU"
EndSection

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
  BusID "PCI:1:0:0"
EndSection

hedmo@mya51 ~ $

and this log to is:
nvidia-bug-report.log.gz (1.16 MB)

Ok, the setup is correct now but I only now notice that the internal display is connected to the nvidia gpu, you’ll probably have to switch to optimus mode in bios. Please check for an option there.

i dont have that option in bios.

Please check for a bios upgrade. If there’s no option to switch the display to the igpu it would be pretty useless to put it in.

Looks like you’re out of luck:
http://forum.notebookreview.com/threads/official-alienware-area-51m-owners-lounge.826831/page-912#post-10902158
Rather stupid design. Please contact Dell if there’s some unknown method.

there was an update and i have updated bios now but still no option for swishing gpu.

Yes, looks like only the thunderbolt connector is connected to the igpu. You’d have to bug Dell. Until then, using the igpu is not possible.