Patch for NVIDIA 96.43.23 and Linux 3.11 needed

Hi
I know that this driver is not developed but NVIDIA installator does not build modules on recent kernels.
I have Ubuntu.
Any links?

ERROR: The kernel header file
       '/lib/modules/3.11.0-13-generic/build/include/linux/version.h' does not
       exist.  The most likely reason for this is that the kernel source files
       in '/lib/modules/3.11.0-13-generic/build' have not been configured.

I solved this by using:

sudo ln -s /lib/modules/3.11.0-13-generic/build/include/generated/uapi/linux/version.h /lib/modules/3.11.0-13-generic/build/include/linux/version.h

but the patch is still necessary…

It seems there are some patches.

building modules 100%, ERROR, failed

OK I have modified sources manually and it works!
Here is the link for drivers:

NVIDIA-Linux-x86-96.43.23-pkg1-modded.run

It should work with recent kernels 3.10, 3.11, …

Please, supply a patch as a plain text file or inside a code tag - no one will download your custom run file - you might as well have embedded malware in it.

On Linux malware? It is safe, dude.

Linux for sure is sfaer than other OS, but maybe you are not… the patch would allow the fix to be included in the official release also…

Do not expect me to sign it by a certificate…
Here are the patches:
https://aur.archlinux.org/packages/nvidia-96xx/?setlang=en&comments=all
but you have to edit it manually. Debian got the package: nvidia-graphics-drivers-legacy-96xx with changes applied also.

What is happening now with the patch input? Will there be an official Nvidia patch for the 96.43.23 in near future or do I have to use the provided in message #5? I need the patch for Opensuse 13.1 which is using Kernel 3.11.6

2014-01-02:
I tested this driver on openSUsE 13.1 with X-server 7.6.1.14.3.901-4.1 compiling is not the problem, but after reboot the X-server detects a modified video interface, proposes a command line parameter and stops. Adding this parameter the X-server crashes. A solution is either downgrading the X-system, or someone is able to change the sources of the 96-package or forget it…

Hi all,

I am just trying to install elementary OS Freya 0.3.1 (based on Ubuntu 14.04 LTS) on an old Toshiba Satellite Pro 2100 with Geforce4 420 Go GPU. The default nouveau-based driver fails upon login via LightDM and I can only use the system when starting in rescue mode. This, of course, gives an extremely bad and practically useless graphics performance.

So I thought I go for the good old nvidia legacy driver (http://www.nvidia.com/object/unix.html), which is v96.43.23 for my card. I downloaded it, installed dependencies and disabled Nouveau as described e.g. on https://gist.github.com/jansanchez/ce5b0ca1c5e538f4b266. So far so good.

The nvidia installer was not working. Obviously, the latest supported kernel is 2.6.

So I googled and found this page along with the modded driver from luk1don. Tried it, failed. Then, I symlinked linux/version.h so that the installer can find it (btw, this was also suggested on http://slackblogs.blogspot.de/2012/12/linux-kernel-37-vmware-workstation-and.html). Still not working.

This is what happens with the modded 96.43.23 driver:

The distribution-provided pre-install script failed! Continue anyway? [YES]
Building kernel module: … 43% … 100%
ERROR: Unable to load the kernel module ‘nvidia.ko’. This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources … [OK]
ERROR: Installation has failed. [OK]

The /var/log/nvidia-installer.log says:

Kernel module load error: insmod: ERROR: could not insert module nvidia.ko: Invalid module format

nvidia: disagrees about version of symbol module_layout

Here some more pieces of information:

‘Xorg -version’ -> 1.17.1
‘uname -r’ -> 3.19.0-26-generic
‘lspci | grep VGA’ -> NVIDIA Corporation NV17M [Geforce4 420 Go] (rev a3)

Is it not working, because of my kernel version 3.19 > 3.11?
Can anyone help?

Thanks,
NewtoM

Forget that driver, it’s 3 Years old and eos.
Buy recent hardware or use nouveau, which should work with this old hardware.

I disagree.

I don’t want to buy new hardware. I want to use the old hardware (old is relative, it has an 1.9 GHz Pentium processor), because it perfectly fits my needs (playing xvid movies and nothing more), but I want to get rid of windows.

And well, I tried nouveau, but it did NOT work.

And now?
What do you think will be?

Nvidia will not help you, since thos hardware is 13 years old.
No one will or can patch this driver for recent kernel and recent xserver.
So be happy with that old piece of crap and stay on your own.

Btw, “dit NOT work” is saying zero!

Ping the people in #nouveau on Freenode.

Thanks, blackout24.

Ok, I have been to https://webchat.freenode.net/ on the channel #Nouveau . The protocol should be available under http://people.freedesktop.org/~cbrill/dri-log/index.php?channel=dri-devel&date=2015-09-24 .

Here is the essence of the talk:

  • Nouveau does indeed support my old piece of hardware (Geforce4 420 Go, NV17M).
  • The Gnome/Pantheon desktop environment tries to use OpenGL features, which the card does not support, and that is why X crashes after logging-in.
  • To fix that, you either put LIBGL_ALWAYS_SOFTWARE=1 into /etc/environment and restart X (but this leads to very poor performance), or
  • You change e.g. to xfce (http://www.xfce.org/), which is a really light-weight desktop environment. See e.g. http://www.howtogeek.com/193129/how-to-install-and-use-another-desktop-environment-on-linux/ on how to install xfce4.

Now that I got rid of Gnome/Pantheon and use xfce4 (with some extra settings available via xfce4-settings-manager under “tweaks of window manager”/“compositions” -> shadows under windows etc.) I am very satisfied. The “old” hardware now has a nice look and feel and is very responsive.

I wish Elementary OS builders would make xfce4 first choice for old hardware.