PGPROF exits with JAVA error

pgprof is not working on my linux system. The program exits with a java error message:

java: /build/buildd/gtk2-engines-oxygen-1.4.5/src/animations/oxygencomboboxdata.cpp:87: void Oxygen::ComboBoxData::setButton(GtkWidget*...

pgprof --version:
pgprof 16.1

What is wrong?

Hi hendrun,

What Linux version and Java are you using?

When there’s an error, there should be a message something like: “An error has occurred. See the log file nvvp-workspace/.metadata/.log”. Where “nvvp-workspace” is located in your $HOME directory. If this error log exists, can you post or send it to PGI Customer Service (trs@pgroup.com)?

Thanks,
Mat

There was no error message like “An error has occured…”
Only: “java: /build/buildd/gtk2-engines-oxygen-1.4.5/src/animations/oxygencomboboxdata.cpp:87: void Oxygen::ComboBoxData::setButton(GtkWidget*): Zusicherung »!_button._widget« nicht erfüllt.”

$ more /etc/issue
Ubuntu 14.04.4 LTS

$ which java
/usr/bin/java

$ java -version
java version "1.7.0_95"
OpenJDK Runtime Environment (IcedTea 2.6.4) (7u95-2.6.4-0ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)

$ more ~/nvvp_workspace/.metadata/.log
!SESSION 2016-02-25 09:51:13.914 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=de_DE
Framework arguments:  -product com.nvidia.pgprof.application.product
Command-line arguments:  -os linux -ws gtk -arch x86_64 -data @user.home/nvvp_workspace -product com.nvidia.pgprof.application.product

!ENTRY org.eclipse.core.resources 2 10035 2016-02-25 09:51:15.522
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.

!ENTRY org.eclipse.ui 4 4 2016-02-25 09:51:16.987
!MESSAGE Referenced part does not exist yet: org.eclipse.ui.editors.
!SESSION 2016-02-25 09:52:43.460 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=de_DE
Framework arguments:  -product com.nvidia.pgprof.application.product
Command-line arguments:  -os linux -ws gtk -arch x86_64 -data @user.home/nvvp_workspace -product com.nvidia.pgprof.application.product

!ENTRY org.eclipse.core.resources 2 10035 2016-02-25 09:52:44.990
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.

!ENTRY org.eclipse.ui 4 4 2016-02-25 09:52:46.440
!MESSAGE Referenced part does not exist yet: org.eclipse.ui.editors.

And this is how I can reproduce this error:

Start pgprof
click File -> Import
choose ‘PGPROF’, click Next
choose ‘single process’, click Next.

This is all…

Issue solved. There is a known bug in GKT that can be easily fixed as described here:

http://stackoverflow.com/questions/26436009/eclipse-luna-crashes-on-new-project-in-ubuntu