Poor performance with a MCX312B-XCCT

Hi, I installed on a QNAP 1677X NAS and on my PC a Mellanox MCX312B-XCCT dual port card, SFP+ having less latency than RJ-45. The QNAP 1677X NAS internal tests shows a read speed of 1790 MB/s.

With an 20Gbs LAG connection, using a high end Netgear M4300-12X12F switch, I only get 650MBs read and 450Bs write speed. I use an Asrock X79 Extreme9 mobo with an I7-3930K processor overclocked to a constant 4.4GHz speed and Windows 7 x64.

An older PC, using a much lower end MSI B85-G41 PC Mate(MS-7850) mobo with a single link 10Gbs Mellanox card reaches 652r/919w speed. That’s double the write speed with an inferior hardware.

I tried to remove all the other PCI cards, except the graphic card of course, and tested all the PCI slot, without any increase.

Using a RJ-45 10Gbs card gives me half the SFP+ card, so the Mellanox is much better, but far from reaching the speed of the device it is connected too. Connecting directly to the NAS, without the switch, very slightly impoves the speed.

There seems to be something wrong here, is there any setting I can change to reach the full speed?

Hello Robert,

I hope all is good. Have you tried the Mellanox Performance Tuning Guide? https://community.mellanox.com/s/article/performance-tuning-for-mellanox-adapters

Also, please keep in mind your Asrock X79 Extreme9 MB is not a datacenter class server and may not be designed to facilitate full BW of these NICs. You could contact them to verify.

Many thanks ,


Hi Stephen,

Yes, the mobo is probably the culprit. I contacted ASRock support, but everything they suggested to do I already had.

I’m using a 8x GEN3 PCI slot, so it’s the best that’s needed.

I looked at the guide, but it details mainly commands for Linux systems. Picture for BIOS setting are largely outdated compared to modern UEFIs, but I got the gist and I think that there nothing more to do on my system to improve.

I also tried one of the new RJ-45 10GB cards, but the performance was half of the Mellanox, so Mellanox SFP+ has quite an edge on my system, even though it does not reach the potential of the NAS.

My main problem is that I absolutely hate Windows 10, so I can’t change for a better mobo and processor, Windows 7 has been locked out by Microsoft.

Anyway, thanks for your help, I don’t think I can do better, none of the concerned vendors (you, ASRock and QNAP) has been able to suggest a solution other than better PC hardware.