PreserveVideoMemoryAllocations + systemd services causes resume from hibernate to fail

So, I tried setting NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/var/tmp and enabling the systemd power management services (-resume, -hibernate, -suspend), and I can’t successfully resume from hibernation anymore!

Reposting part of my journal:

kernel: NVRM: GPU 0000:01:00.0: PreserveVideoMemoryAllocations module parameter is set. System Power Management attempted without driver procfs suspend interface. Please refer to the 'Configuring Power Management Support' section in the driver README.
kernel: nvidia 0000:01:00.0: PM: pci_pm_freeze(): nv_pmops_freeze+0x0/0x40 [nvidia] returns -5
kernel: nvidia 0000:01:00.0: PM: dpm_run_callback(): pci_pm_freeze+0x0/0x140 returns -5
kernel: nvidia 0000:01:00.0: PM: failed to quiesce async: error -5
kernel: ucsi_acpi USBC000:00: PM: dpm_run_callback(): ucsi_acpi_resume+0x0/0x40 [ucsi_acpi] returns -110
kernel: ucsi_acpi USBC000:00: PM: failed to recover: error -110
kernel: PM: hibernation: Failed to load image, recovering.

Anyone has any idea what could be the reason? Why would nv_pmops_freeze fail with -5?

Same issue on my laptop gigabyte g5 gd. Linux 6.0.8
I have enabled nvidia-suspend,hibernate,resume services, rerun mkinitcpio.
I have made sure that nvidia-hibernate is run on hibernate(I see it in logs)
But still have the same issue as described above

I have fixed my issue by DISABLING early-kms.
In my case - removing nvidia and intel modules from mkinitcpio.conf